summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-09-05 09:06:30 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-09-05 09:07:06 +0200
commitf3d19697e96e0ce4d32484dc6ebf88c139ac710c (patch)
tree91965ff549511622c6f73f1876b69f9d5ee81ace /sci-libs
parentmedia-libs/netpbm: drop 11.7.0 (diff)
downloadgentoo-f3d19697e96e0ce4d32484dc6ebf88c139ac710c.tar.gz
gentoo-f3d19697e96e0ce4d32484dc6ebf88c139ac710c.tar.bz2
gentoo-f3d19697e96e0ce4d32484dc6ebf88c139ac710c.zip
sci-libs/caffe2: fix for gcc-15
Closes: https://bugs.gentoo.org/939069 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/caffe2/caffe2-2.4.0-r1.ebuild1
-rw-r--r--sci-libs/caffe2/files/caffe2-2.4.0-cstdint.patch10
2 files changed, 11 insertions, 0 deletions
diff --git a/sci-libs/caffe2/caffe2-2.4.0-r1.ebuild b/sci-libs/caffe2/caffe2-2.4.0-r1.ebuild
index d8e42de52185..e990c18926b2 100644
--- a/sci-libs/caffe2/caffe2-2.4.0-r1.ebuild
+++ b/sci-libs/caffe2/caffe2-2.4.0-r1.ebuild
@@ -126,6 +126,7 @@ PATCHES=(
../patches/${PN}-2.3.0-fix-libcpp.patch
"${FILESDIR}"/${PN}-2.4.0-libfmt-11.patch
"${FILESDIR}"/${P}-cpp-httplib.patch
+ "${FILESDIR}"/${P}-cstdint.patch
)
src_prepare() {
diff --git a/sci-libs/caffe2/files/caffe2-2.4.0-cstdint.patch b/sci-libs/caffe2/files/caffe2-2.4.0-cstdint.patch
new file mode 100644
index 000000000000..f248ab031eb0
--- /dev/null
+++ b/sci-libs/caffe2/files/caffe2-2.4.0-cstdint.patch
@@ -0,0 +1,10 @@
+--- a/caffe2/utils/string_utils.cc 2024-09-05 08:29:06.930438069 +0200
++++ b/caffe2/utils/string_utils.cc 2024-09-05 08:29:28.398137596 +0200
+@@ -3,6 +3,7 @@
+ #include <algorithm>
+ #include <sstream>
+ #include <vector>
++#include <cstdint>
+
+ namespace caffe2 {
+