summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-03-27 17:14:53 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-03-27 17:14:53 +0700
commit5196f502351af4efc6278c817e2d0ec3abd4128a (patch)
tree88b639938de9ededcdf3fe53a542857782147562 /sci-mathematics/fricas
parentsci-mathematics/fricas: fix building with sbcl-2.3.2 (diff)
downloadgentoo-5196f502351af4efc6278c817e2d0ec3abd4128a.tar.gz
gentoo-5196f502351af4efc6278c817e2d0ec3abd4128a.tar.bz2
gentoo-5196f502351af4efc6278c817e2d0ec3abd4128a.zip
sci-mathematics/fricas: remove old
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/fricas')
-rw-r--r--sci-mathematics/fricas/Manifest1
-rw-r--r--sci-mathematics/fricas/fricas-1.3.7.ebuild110
-rw-r--r--sci-mathematics/fricas/fricas-1.3.8.ebuild110
3 files changed, 0 insertions, 221 deletions
diff --git a/sci-mathematics/fricas/Manifest b/sci-mathematics/fricas/Manifest
index d23c3bae95e9..276c12bbc607 100644
--- a/sci-mathematics/fricas/Manifest
+++ b/sci-mathematics/fricas/Manifest
@@ -1,2 +1 @@
-DIST fricas-1.3.7-full.tar.bz2 38008318 BLAKE2B 079a0e2739c0f28c7fb76681e9562802cd7d6f16a0a0bcd8310bb11a6678b2aeabca9cc8effdf81d9464742bf4a20d07845f870717326afbd87feb48fe408493 SHA512 fd3742eb56c279adcdbae62a8eb5843781d0da4318f1b6e55310a9ac243c712b24fef214414c8d656b222be890ec4d9d30ad243b77b8eeaeea95e0ae3dda890a
DIST fricas-1.3.8-full.tar.bz2 10878913 BLAKE2B 214eecd430a2b758a10d985f512f3c79f6b12de35bc29e8f0a3fd296fe871b2e9a6b362060cbeec317dc355bd3c661fcab44087feeaa092fe6afcdebd0fb94a8 SHA512 330554f9dc36b47451195e3dee88fe26a80ab2bf9b6750d651cd53c5ba16b9c9736176936c7c69e699685be25aa62b6a099ed7340913e946a4f5e53579835dbb
diff --git a/sci-mathematics/fricas/fricas-1.3.7.ebuild b/sci-mathematics/fricas/fricas-1.3.7.ebuild
deleted file mode 100644
index eefad5493a0a..000000000000
--- a/sci-mathematics/fricas/fricas-1.3.7.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit multilib elisp-common
-
-DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
-HOMEPAGE="http://fricas.sourceforge.net/
- https://github.com/fricas/fricas
- https://fricas.github.io/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.bz2"
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Supported lisps, number 0 is the default
-LISPS=( sbcl cmucl gcl ecls clisp clozurecl )
-# Version restrictions, . means no restrictions
-REST=( . . . . . . )
-# command name: . means just ${LISP}
-COMS=( . lisp . ecl . ccl )
-
-IUSE="${LISPS[*]} X emacs gmp"
-RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
- emacs? ( >=app-editors/emacs-23.1:* )
- gmp? ( dev-libs/gmp:= )"
-
-# Generating lisp deps
-n=${#LISPS[*]}
-for ((n--; n > 0; n--)); do
- LISP=${LISPS[$n]}
- if [ "${REST[$n]}" = "." ]; then
- DEP="dev-lisp/${LISP}"
- else
- DEP="${REST[$n]}"
- fi
- RDEPEND="${RDEPEND} ${LISP}? ( ${DEP}:= ) !${LISP}? ("
-done
-if [ "${REST[0]}" = "." ]; then
- DEP="dev-lisp/${LISPS[0]}"
-else
- DEP="${REST[0]}"
-fi
-RDEPEND="${RDEPEND} ${DEP}:="
-n=${#LISPS[*]}
-for ((n--; n > 0; n--)); do
- RDEPEND="${RDEPEND} )"
-done
-
-DEPEND="${RDEPEND}"
-
-# necessary for clisp and gcl
-RESTRICT="strip"
-
-src_configure() {
- local LISP n GMP
- LISP=sbcl
- n=${#LISPS[*]}
- for ((n--; n > 0; n--)); do
- if use ${LISPS[$n]}; then
- LISP=${COMS[$n]}
- if [ "${LISP}" = "." ]; then
- LISP=${LISPS[$n]}
- fi
- fi
- done
- einfo "Using lisp: ${LISP}"
-
- # bug #650788
- if [[ ${LISP} = sbcl || ${LISP} = ccl ]]
- then GMP=$(use_with gmp)
- else GMP=''
- fi
-
- # aldor is not yet in portage
- econf --disable-aldor --with-lisp=${LISP} $(use_with X x) ${GMP}
-}
-
-src_compile() {
- # bug #300132
- emake -j1
-}
-
-src_test() {
- emake -j1 all-input
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install
- dodoc README.rst FAQ
-
- if use emacs; then
- sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
- -i "${D}"/usr/bin/efricas \
- || die "sed efricas failed"
- elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
- elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
- else
- rm "${D}"/usr/bin/efricas || die "rm efricas failed"
- fi
- rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/fricas/fricas-1.3.8.ebuild b/sci-mathematics/fricas/fricas-1.3.8.ebuild
deleted file mode 100644
index 2d11d0c22808..000000000000
--- a/sci-mathematics/fricas/fricas-1.3.8.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit elisp-common
-
-DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
-HOMEPAGE="http://fricas.sourceforge.net/
- https://github.com/fricas/fricas
- https://fricas.github.io/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.bz2"
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Supported lisps, number 0 is the default
-LISPS=( sbcl cmucl gcl ecls clisp clozurecl )
-# Version restrictions, . means no restrictions
-REST=( . . . . . . )
-# command name: . means just ${LISP}
-COMS=( . lisp . ecl . ccl )
-
-IUSE="${LISPS[*]} X emacs gmp"
-RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
- emacs? ( >=app-editors/emacs-23.1:* )
- gmp? ( dev-libs/gmp:= )"
-
-# Generating lisp deps
-n=${#LISPS[*]}
-for ((n--; n > 0; n--)); do
- LISP=${LISPS[$n]}
- if [ "${REST[$n]}" = "." ]; then
- DEP="dev-lisp/${LISP}"
- else
- DEP="${REST[$n]}"
- fi
- RDEPEND="${RDEPEND} ${LISP}? ( ${DEP}:= ) !${LISP}? ("
-done
-if [ "${REST[0]}" = "." ]; then
- DEP="dev-lisp/${LISPS[0]}"
-else
- DEP="${REST[0]}"
-fi
-RDEPEND="${RDEPEND} ${DEP}:="
-n=${#LISPS[*]}
-for ((n--; n > 0; n--)); do
- RDEPEND="${RDEPEND} )"
-done
-
-DEPEND="${RDEPEND}"
-
-# necessary for clisp and gcl
-RESTRICT="strip"
-
-src_configure() {
- local LISP n GMP
- LISP=sbcl
- n=${#LISPS[*]}
- for ((n--; n > 0; n--)); do
- if use ${LISPS[$n]}; then
- LISP=${COMS[$n]}
- if [ "${LISP}" = "." ]; then
- LISP=${LISPS[$n]}
- fi
- fi
- done
- einfo "Using lisp: ${LISP}"
-
- # bug #650788
- if [[ ${LISP} = sbcl || ${LISP} = ccl ]]
- then GMP=$(use_with gmp)
- else GMP=''
- fi
-
- # aldor is not yet in portage
- econf --disable-aldor --with-lisp=${LISP} $(use_with X x) ${GMP}
-}
-
-src_compile() {
- # bug #300132
- emake -j1
-}
-
-src_test() {
- emake -j1 all-input
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install
- dodoc README.rst FAQ
-
- if use emacs; then
- sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
- -i "${D}"/usr/bin/efricas \
- || die "sed efricas failed"
- elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
- elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
- else
- rm "${D}"/usr/bin/efricas || die "rm efricas failed"
- fi
- rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}