summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2019-09-23 14:37:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-23 16:37:32 +0300
commit38ad2c47e1945f24d061d888a2384b76013fbaf1 (patch)
treedea732d1b2fc740d4aa8ae91bbb720929af8fe80 /sci-mathematics/gimps/gimps-29.8.6.ebuild
parentmedia-fonts/cascadia-code: New ebuild (diff)
downloadgentoo-38ad2c47e1945f24d061d888a2384b76013fbaf1.tar.gz
gentoo-38ad2c47e1945f24d061d888a2384b76013fbaf1.tar.bz2
gentoo-38ad2c47e1945f24d061d888a2384b76013fbaf1.zip
sci-mathematics/gimps: version bump to version 29.8b6
Also bump to EAPI-7 Closes: https://bugs.gentoo.org/694962 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-mathematics/gimps/gimps-29.8.6.ebuild')
-rw-r--r--sci-mathematics/gimps/gimps-29.8.6.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/gimps-29.8.6.ebuild b/sci-mathematics/gimps/gimps-29.8.6.ebuild
new file mode 100644
index 000000000000..ead2bcedc1c0
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-29.8.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils systemd readme.gentoo-r1
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="https://www.mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(ver_rs 2 'b' )
+
+SRC_URI="
+ amd64? ( ftp://mersenne.org/gimps/p95v${MY_PV/./}.linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/p95v${MY_PV/./}.linux32.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64 ~x86"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt whatsnew.txt undoc.txt )
+
+src_install() {
+ dodir ${I}
+ keepdir /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}" || die
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}