summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2025-01-14 15:55:17 -0500
committerMichael Orlitzky <mjo@gentoo.org>2025-01-14 15:55:17 -0500
commit1e0fa28fbbf58cb42e4298ad1321d74c94c78984 (patch)
tree5df7576b307729bebab405fb17023e5137ae6438 /sci-mathematics
parentsys-kernel/ugrd: drop 1.13, 1.17, 1.25, 1.26 (diff)
downloadgentoo-1e0fa28fbbf58cb42e4298ad1321d74c94c78984.tar.gz
gentoo-1e0fa28fbbf58cb42e4298ad1321d74c94c78984.tar.bz2
gentoo-1e0fa28fbbf58cb42e4298ad1321d74c94c78984.zip
sci-mathematics/gfan: drop 0.6.2-r4
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gfan/gfan-0.6.2-r4.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/sci-mathematics/gfan/gfan-0.6.2-r4.ebuild b/sci-mathematics/gfan/gfan-0.6.2-r4.ebuild
deleted file mode 100644
index fe1b428750be..000000000000
--- a/sci-mathematics/gfan/gfan-0.6.2-r4.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Compute Groebner fans and tropical varieties"
-HOMEPAGE="https://users-math.au.dk/~jensen/software/gfan/gfan.html"
-SRC_URI="https://users-math.au.dk/~jensen/software/${PN}/${PN}${PV}.tar.gz"
-
-S="${WORKDIR}/${PN}${PV}"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-BDEPEND="doc? ( virtual/latex-base )"
-DEPEND="dev-libs/gmp:0=[cxx(+)]
- sci-libs/cddlib:0="
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.6.2-xcode9.3_compat.patch"
- "${FILESDIR}/${PN}-0.6.2-testsuite.patch"
- "${FILESDIR}/${PN}-0.6.2-Makefile.patch"
- )
-
-pkg_setup() {
- tc-export CC CXX
-
- # This should really go in cppflags, but that doesn't work with
- # gfan's hand-written Makefile.
- append-cxxflags -DNOCDDPREFIX -I"${EPREFIX}"/usr/include/cddlib
-}
-
-src_prepare() {
- default
-
- # This test hangs on x86, bug 717112.
- rm -r testsuite/0602ResultantFanProjection || \
- die "unable to disable test 0602ResultantFanProjection"
-
- # And this one fails (harmlessly) on x86, bug 818397.
- rm -r testsuite/0009RenderStairCase || \
- die "unable to disable test 0009RenderStairCase"
-}
-
-src_configure() {
- # -Werror=odr
- # https://bugs.gentoo.org/863044
- # Only contact method is email. I have sent one detailing the issue.
- filter-lto
-
- # The upstream Makefile says that GCC produces bad code with -O3.
- replace-flags "-O3" "-O2"
- default
-}
-
-src_compile() {
- default
- if use doc; then
- pushd doc > /dev/null || die
- # The LaTeX build commands need to be repeated until the
- # document "stops changing," which is not as easy as it
- # sounds to detect. Running it twice seems to work here.
- for iteration in 1 2; do
- latex manual.tex && \
- bibtex manual && \
- dvipdf manual.dvi manual.pdf || die
- done
- popd > /dev/null || die
- fi
-}
-
-src_install() {
- emake PREFIX="${ED}/usr" install
- use doc && dodoc doc/manual.pdf
-}