summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-15 15:57:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-15 19:21:54 +0200
commita5c92115f792ebe4ade575a9a1026b8abfa1bd8b (patch)
treedb1c69811774ec4d908be19ffb425e18e456e930 /sci-mathematics
parentapp-emacs/racket-mode: drop old 0_p20220830 (diff)
downloadgentoo-a5c92115f792ebe4ade575a9a1026b8abfa1bd8b.tar.gz
gentoo-a5c92115f792ebe4ade575a9a1026b8abfa1bd8b.tar.bz2
gentoo-a5c92115f792ebe4ade575a9a1026b8abfa1bd8b.zip
sci-mathematics/opensmt: bump to 2.5.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/opensmt/Manifest1
-rw-r--r--sci-mathematics/opensmt/opensmt-2.5.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sci-mathematics/opensmt/Manifest b/sci-mathematics/opensmt/Manifest
index cfff6834edf3..5c761352c1a5 100644
--- a/sci-mathematics/opensmt/Manifest
+++ b/sci-mathematics/opensmt/Manifest
@@ -1 +1,2 @@
DIST opensmt-2.4.3.tar.gz 1912077 BLAKE2B d945d5b85d81b9b991f2f881f2d8f160dbefad8ce6484cf0d28c9a35c0fa64d18f45442a59cdd45bd29fcf526a09717d902d30376dfe2784de2d4df9627f803b SHA512 a2adbbdebb133d7e97428c0ac9bf4c2413c95bca61567c5475f889f550904fc33a385712536c9026b38a1645b73c943876fa36724b634db061cb7cc0932543f2
+DIST opensmt-2.5.0.tar.gz 1940493 BLAKE2B ee643815b9da8bdc4a3a074a438eacdfde778347f4090aa7403e34859a9d51a17db8992c38a0e9f7a808384b0413abfbe2aa7b360dda44181344528159666945 SHA512 d70972eae376b927694f893ff9b6e4bfba7d0cfffe63545b5a0d582b594c3538643c9ae0121e75cf85aec3876eb4a45df2766c3a7700d07da05d1d6081953f42
diff --git a/sci-mathematics/opensmt/opensmt-2.5.0.ebuild b/sci-mathematics/opensmt/opensmt-2.5.0.ebuild
new file mode 100644
index 000000000000..479c6c7e252f
--- /dev/null
+++ b/sci-mathematics/opensmt/opensmt-2.5.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Compact and open-source SMT-solver written in C++"
+HOMEPAGE="http://verify.inf.usi.ch/opensmt/
+ https://github.com/usi-verification-and-security/opensmt/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/usi-verification-and-security/${PN}.git"
+else
+ SRC_URI="https://github.com/usi-verification-and-security/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="debug libedit +readline test"
+REQUIRED_USE="?? ( libedit readline )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/gmp:=[cxx]
+ readline? ( sys-libs/readline:= )
+ libedit? ( dev-libs/libedit:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ test? ( dev-cpp/gtest )
+"
+
+# PATCHES=( "${FILESDIR}"/${PN}-2.4.3-musl.patch )
+
+src_prepare() {
+ cmake_src_prepare
+
+ echo "add_subdirectory(unit)" > "${S}"/test/CMakeLists.txt || die
+}
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug ; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ local -a mycmakeargs=(
+ -DPACKAGE_TESTS=$(usex test)
+ -DUSE_READLINE=$(usex readline)
+ )
+ if use readline || use libedit ; then
+ mycmakeargs+=( -DENABLE_LINE_EDITING=ON )
+ fi
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ rm "${ED}"/usr/lib/libopensmt.a || die
+ dodir /usr/$(get_libdir)
+ mv "${ED}"/usr/lib/libopensmt.* "${ED}"/usr/$(get_libdir)/ || die
+}