summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-15 09:42:43 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-15 09:42:43 +0100
commitb51446da93bc69c1609fb14207ed0e29679e5ed7 (patch)
tree4653b336639c29406eefdaec6362c7f7a0778d80 /sci-mathematics
parentsci-electronics/espresso-ab: Port to EAPI 7 (diff)
downloadgentoo-b51446da93bc69c1609fb14207ed0e29679e5ed7.tar.gz
gentoo-b51446da93bc69c1609fb14207ed0e29679e5ed7.tar.bz2
gentoo-b51446da93bc69c1609fb14207ed0e29679e5ed7.zip
sci-mathematics/4ti2: Port to EAPI 7
Bug: https://bugs.gentoo.org/770634 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/4ti2/4ti2-1.6.7.ebuild15
-rw-r--r--sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch6
2 files changed, 5 insertions, 16 deletions
diff --git a/sci-mathematics/4ti2/4ti2-1.6.7.ebuild b/sci-mathematics/4ti2/4ti2-1.6.7.ebuild
index ec2bd5017ed2..0307e26bdbae 100644
--- a/sci-mathematics/4ti2/4ti2-1.6.7.ebuild
+++ b/sci-mathematics/4ti2/4ti2-1.6.7.ebuild
@@ -1,27 +1,24 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
-HOMEPAGE="http://www.4ti2.de/"
+HOMEPAGE="https://4ti2.github.io"
SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
RDEPEND="
sci-mathematics/glpk:=[gmp]
dev-libs/gmp:0=[cxx]"
DEPEND="${RDEPEND}"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.3.2-gold.patch
-)
+PATCHES=( "${FILESDIR}"/${PN}-1.3.2-gold.patch )
src_prepare() {
default
@@ -33,13 +30,11 @@ src_prepare() {
src_configure() {
econf \
--enable-shared \
- $(use_enable static-libs static)
+ --disable-static
}
src_install() {
default
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch b/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch
index bb1e8c4aad39..9037e9836375 100644
--- a/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch
+++ b/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch
@@ -1,9 +1,3 @@
- m4/glpk-check.m4 | 2 +-
- src/groebner/Makefile.am | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/groebner/Makefile.am b/src/groebner/Makefile.am
-index 992c4ae..ba2f463 100644
--- a/src/groebner/Makefile.am
+++ b/src/groebner/Makefile.am
@@ -269,7 +269,7 @@ lib4ti2int64_la_SOURCES = $(lib4ti2sources)