summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-08-29 18:48:07 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-08-29 18:48:07 +0700
commitf9022e15a1d75f090f06ee6299d73364d0284065 (patch)
treecccfe8dc8e9a2ec6e754bf10a7d92783e3c7094a /sci-mathematics
parentdev-python/qiskit-aer: Bump to 0.12.2 (diff)
downloadgentoo-f9022e15a1d75f090f06ee6299d73364d0284065.tar.gz
gentoo-f9022e15a1d75f090f06ee6299d73364d0284065.tar.bz2
gentoo-f9022e15a1d75f090f06ee6299d73364d0284065.zip
sci-mathematics/ginac: bump to 1.8.7
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/ginac/Manifest1
-rw-r--r--sci-mathematics/ginac/ginac-1.8.7.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-mathematics/ginac/Manifest b/sci-mathematics/ginac/Manifest
index 56613b5a6eaa..ff11e9077436 100644
--- a/sci-mathematics/ginac/Manifest
+++ b/sci-mathematics/ginac/Manifest
@@ -1 +1,2 @@
DIST ginac-1.8.6.tar.bz2 1152914 BLAKE2B 3d3d655cde0f5444fa01b0dde62a48d3c42b5a3b27e00d9608c56677fd031e639b7e4e6ac7c6cf68f807033cbe81432148d5525d76ad176b8dcd0d80aece07a1 SHA512 b10402d722e8216374dabdee9eba9e6de3b6afebd291a368697eb8efcd0eb8148237628bfb74713771c99977ccc46d972bacccaead3fcf35a1ab328744a7fb48
+DIST ginac-1.8.7.tar.bz2 1153952 BLAKE2B 272a9603741d43d4ba4f7ac3478aac405490cf747e20a5f77d7d6c672c6aee972ab77ddf4cd68daa3c432ea0b02a46ba295311967c2c5a2135bf34070a25f272 SHA512 29a5dbe1fa8a40668a32eb0065d1f676b074222d76ed70a05c5841a4be92c4b1a019ae3fc820e1c7007e641ef8ef94d00adab901f89673df0d372a4c8af8e51a
diff --git a/sci-mathematics/ginac/ginac-1.8.7.ebuild b/sci-mathematics/ginac/ginac-1.8.7.ebuild
new file mode 100644
index 000000000000..4d0ac0c66bb6
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.8.7.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-any-r1
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="http://www.ginac.de/${P}.tar.bz2"
+HOMEPAGE="https://www.ginac.de/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-fontsrecommended
+ media-gfx/transfig
+ dev-texlive/texlive-latexextra
+ virtual/texi2dvi
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.8.2-pkgconfig.patch )
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ --disable-static
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ local -x VARTEXFONTS="${T}"/fonts
+ emake -C doc/reference html pdf
+ emake -C doc/tutorial ginac.pdf ginac.html
+ fi
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ pushd doc >/dev/null || die
+ newdoc tutorial/ginac.pdf tutorial.pdf
+ newdoc reference/reference.pdf reference.pdf
+
+ docinto html/reference
+ dodoc -r reference/html_files/.
+
+ docinto html
+ newdoc tutorial/ginac.html tutorial.html
+ popd >/dev/null || die
+ fi
+
+ if use examples; then
+ pushd doc >/dev/null || die
+ docinto examples
+ dodoc examples/*.cpp examples/ginac-examples.*
+ docompress -x /usr/share/doc/${PF}/examples
+ popd >/dev/null || die
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}