summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-18 03:35:22 +0000
committerSam James <sam@gentoo.org>2022-12-18 04:01:26 +0000
commit98d1217fd34bc35ff285f57812ade0f517b436b4 (patch)
tree996374ce3c73e6d792fa008d3c929675ac10eebd /sci-misc/lttoolbox/files
parentsci-misc/lttoolbox: add github upstream metadata (diff)
downloadgentoo-98d1217fd34bc35ff285f57812ade0f517b436b4.tar.gz
gentoo-98d1217fd34bc35ff285f57812ade0f517b436b4.tar.bz2
gentoo-98d1217fd34bc35ff285f57812ade0f517b436b4.zip
sci-misc/lttoolbox: add 3.7.1
Closes: https://bugs.gentoo.org/851186 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-misc/lttoolbox/files')
-rw-r--r--sci-misc/lttoolbox/files/lttoolbox-3.7.1-bashism.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-misc/lttoolbox/files/lttoolbox-3.7.1-bashism.patch b/sci-misc/lttoolbox/files/lttoolbox-3.7.1-bashism.patch
new file mode 100644
index 000000000000..9727c018b142
--- /dev/null
+++ b/sci-misc/lttoolbox/files/lttoolbox-3.7.1-bashism.patch
@@ -0,0 +1,31 @@
+https://github.com/apertium/lttoolbox/pull/171
+
+From 80408b137ceca94d9dab188277ffa3933b148f3d Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 18 Dec 2022 03:33:03 +0000
+Subject: [PATCH] configure.ac: fix bashism
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+configure scripts need to be runnable with a POSIX-compliant /bin/sh.
+
+On many (but not all!) systems, /bin/sh is provided by Bash, so errors
+like this aren't spotted. Notably Debian defaults to /bin/sh provided
+by dash which doesn't tolerate such bashisms as '=='.
+
+This retains compatibility with bash.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -74,7 +74,7 @@ for version in 23 2b 20 2a 17; do
+ version_flag="-std=c++${version}"
+ AX_CHECK_COMPILE_FLAG([${version_flag}], [break], [version_flag=none])
+ done
+-AS_IF([test "$version_flag" == none], [
++AS_IF([test "$version_flag" = none], [
+ AC_MSG_ERROR([Could not enable at least C++17 - upgrade your compiler])
+ ])
+ CXXFLAGS="$CXXFLAGS ${version_flag}"
+