summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-22 18:28:23 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-25 21:49:07 +0200
commitd9dfe44904c1bd250bd986aea546d0a93163f735 (patch)
tree7b3783cd7d42a753203d6750860c7a51bc82ae55 /sci-misc/vitables/vitables-2.1-r1.ebuild
parentsci-misc/vitables: EAPI bump 4 -> 6 (diff)
downloadgentoo-d9dfe44904c1bd250bd986aea546d0a93163f735.tar.gz
gentoo-d9dfe44904c1bd250bd986aea546d0a93163f735.tar.bz2
gentoo-d9dfe44904c1bd250bd986aea546d0a93163f735.zip
sci-misc/vitables: Removing EAPI 4 ebuild
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2389 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-misc/vitables/vitables-2.1-r1.ebuild')
-rw-r--r--sci-misc/vitables/vitables-2.1-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sci-misc/vitables/vitables-2.1-r1.ebuild b/sci-misc/vitables/vitables-2.1-r1.ebuild
index 5d9caccf2e06..865e0858d70c 100644
--- a/sci-misc/vitables/vitables-2.1-r1.ebuild
+++ b/sci-misc/vitables/vitables-2.1-r1.ebuild
@@ -20,8 +20,8 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples"
RDEPEND="
- dev-python/pytables
- dev-python/PyQt4[X]" # FIXME: check if any other useflags are needed
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]" # FIXME: check if any other useflags are needed
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )"
@@ -30,7 +30,6 @@ S=${WORKDIR}/${MY_P}
PATCHES=( "${FILESDIR}"/${P}-no-docs.patch )
python_compile_all() {
- distutils-r1_python_compile
# fixme: multiple python (anyone cares?)
use doc && esetup.py build_sphinx
}
@@ -38,15 +37,14 @@ python_compile_all() {
python_install_all() {
dodir /usr/share/icons/hicolor/scalable/apps
dodir /usr/share/applications
- distutils-r1_python_install_all
if use examples; then
docompress -x /usr/share/doc/${PF}/examples
DOCS+=( examples )
fi
- if use doc ; then
+ if use doc; then
HTML_DOCS+=( "${BUILD_DIR}"/sphinx/html/. )
DOCS+=( "${BUILD_DIR}"/sphinx/latex/*.pdf )
fi
- einstalldocs
+ distutils-r1_python_install_all
}