summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-08-28 16:48:02 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-08-28 16:48:02 +0200
commit28b39c800b8a3c2786e5c2d0d2ffcce226038529 (patch)
tree781fe5a4d744c5c9884b51303fc60ab13dd6b7de /sci-visualization/dash/dash-1.20.0-r1.ebuild
parentdev-python/setuptools_scm: mask version 6.2.0 (diff)
downloadgentoo-28b39c800b8a3c2786e5c2d0d2ffcce226038529.tar.gz
gentoo-28b39c800b8a3c2786e5c2d0d2ffcce226038529.tar.bz2
gentoo-28b39c800b8a3c2786e5c2d0d2ffcce226038529.zip
sci-visualization/dash: incorrect DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/810448 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-visualization/dash/dash-1.20.0-r1.ebuild')
-rw-r--r--sci-visualization/dash/dash-1.20.0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-visualization/dash/dash-1.20.0-r1.ebuild b/sci-visualization/dash/dash-1.20.0-r1.ebuild
new file mode 100644
index 000000000000..bea53debe740
--- /dev/null
+++ b/sci-visualization/dash/dash-1.20.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python framework for building ML & data science web apps"
+HOMEPAGE="https://github.com/plotly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/future[${PYTHON_USEDEP}]
+ sci-visualization/dash-table[${PYTHON_USEDEP}]
+ sci-visualization/dash-html-components[${PYTHON_USEDEP}]
+ sci-visualization/dash-core-components[${PYTHON_USEDEP}]
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/flask-compress[${PYTHON_USEDEP}]"
+BDEPEND=""
+
+src_prepare() {
+ distutils-r1_src_prepare
+ cd dash-renderer
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ distutils-r1_src_configure
+ cd dash-renderer
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ cd dash-renderer
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ cd dash-renderer
+ distutils-r1_src_install
+}