summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2025-01-26 19:07:44 +0100
committerUlrich Müller <ulm@gentoo.org>2025-01-26 19:18:19 +0100
commit9b91681558064b1e5a0f7186eee3e3369aff14e0 (patch)
tree9155f9a5899f15b34797346c385b398c95f9c6ec /sci-visualization/gnuplot
parentsys-cluster/knem: Update knem to use linux-mod-r1, and drop non-git version (diff)
downloadgentoo-9b91681558064b1e5a0f7186eee3e3369aff14e0.tar.gz
gentoo-9b91681558064b1e5a0f7186eee3e3369aff14e0.tar.bz2
gentoo-9b91681558064b1e5a0f7186eee3e3369aff14e0.zip
sci-visualization/gnuplot: add 6.0.2
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'sci-visualization/gnuplot')
-rw-r--r--sci-visualization/gnuplot/Manifest1
-rw-r--r--sci-visualization/gnuplot/gnuplot-6.0.2.ebuild214
2 files changed, 215 insertions, 0 deletions
diff --git a/sci-visualization/gnuplot/Manifest b/sci-visualization/gnuplot/Manifest
index 6b3f100b9ed2..764b37c923c0 100644
--- a/sci-visualization/gnuplot/Manifest
+++ b/sci-visualization/gnuplot/Manifest
@@ -1,2 +1,3 @@
DIST gnuplot-5.4.10.tar.gz 5687565 BLAKE2B 879159fb4b581aa334b221632af7268047077cd48d89d1cecb0c6c9e855edd40bddfdaa8222177652d6200f81b97b0b52fe719da0641eea817e086832f07664f SHA512 fe5226a243dad62e8617d820764dc5923e76a51a68c58a666a699110f5b5be0f5e759e0586e923472a59ca6d1b30d1093d7a65e9c1d3a36fcd33a95df36ab89f
DIST gnuplot-6.0.1.tar.gz 7528936 BLAKE2B d385d4dc8a4af83f121bd062e014d8845078f5aeb84244f4cce7c17b7cf71c5fc66bd7b8623504ab53567b4123fc739506f7d2f8e4f8ad184258a7568f0223a2 SHA512 47e72ac444f35e22a5de111da3333c80846226d87411a3168e45a8433a258e351ad9b6f0ba21d76f2456042b755123a697b685fd2552b4bd9edc5b97fafcbc62
+DIST gnuplot-6.0.2.tar.gz 7637308 BLAKE2B e06923c89f3f89bcefbf69c469036763d0da5cdc8c860e07631be7bef12a7e2e81b1315aa671c1e6a6948202e860bd0dcd4f0f57c1dba9b9cff37659ce586999 SHA512 5c26c91a91238be0dad91b0835427355b4db526e6a83225219219b3c980e245abcd4b54d1c693523d645c469f3c610658da0c889df691ba8ba6799efe440ed01
diff --git a/sci-visualization/gnuplot/gnuplot-6.0.2.ebuild b/sci-visualization/gnuplot/gnuplot-6.0.2.ebuild
new file mode 100644
index 000000000000..90c9c00cbe7a
--- /dev/null
+++ b/sci-visualization/gnuplot/gnuplot-6.0.2.ebuild
@@ -0,0 +1,214 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1,2,3,4} )
+WX_GTK_VER="3.2-gtk3"
+
+inherit autotools lua-single readme.gentoo-r1 toolchain-funcs wxwidgets
+
+DESCRIPTION="Command-line driven interactive plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+
+if [[ -z ${PV%%*9999} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.code.sf.net/p/gnuplot/gnuplot-main"
+ EGIT_BRANCH="master"
+ MY_P="${PN}"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${MY_P}"
+else
+ MY_P="${P/_/.}"
+ SRC_URI="https://downloads.sourceforge.net/gnuplot/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="gnuplot"
+SLOT="0"
+IUSE="amos aqua bitmap cairo doc examples +gd gpic latex libcaca libcerf lua metafont metapost qt6 readline regis tgif wxwidgets X"
+
+REQUIRED_USE="
+ doc? ( gd )
+ lua? ( ${LUA_REQUIRED_USE} )"
+
+RDEPEND="
+ amos? ( dev-libs/openspecfun )
+ cairo? (
+ x11-libs/cairo
+ x11-libs/pango )
+ gd? ( >=media-libs/gd-2.0.35-r3:2=[png] )
+ latex? (
+ virtual/latex-base
+ lua? (
+ dev-tex/pgf
+ >=dev-texlive/texlive-latexrecommended-2008-r2 ) )
+ libcaca? ( media-libs/libcaca )
+ lua? ( ${LUA_DEPS} )
+ qt6? (
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[gui,network,widgets]
+ dev-qt/qtsvg:6 )
+ readline? ( sys-libs/readline:0= )
+ libcerf? ( sci-libs/libcerf )
+ wxwidgets? (
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/gtk+:3 )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXaw )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-langgreek
+ dev-texlive/texlive-mathscience
+ app-text/ghostscript-gpl )
+ qt6? ( dev-qt/qttools:6[linguist] )"
+
+IDEPEND="latex? ( virtual/latex-base )"
+
+GP_VERSION="${PV%.*}"
+TEXMF="${EPREFIX}/usr/share/texmf-site"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.1-no-picins.patch
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV##*.} = 9999 ]]; then
+ local dir
+ for dir in config demo m4 term tutorial; do
+ emake -C "$dir" -f Makefile.am.in Makefile.am
+ done
+ fi
+
+ # Add special version identification as required by provision 2
+ # of the gnuplot license
+ sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
+
+ eautoreconf
+
+ # Make sure we don't mix build & host flags.
+ sed -i \
+ -e 's:@CPPFLAGS@:$(BUILD_CPPFLAGS):' \
+ -e 's:@CFLAGS@:$(BUILD_CFLAGS):' \
+ -e 's:@LDFLAGS@:$(BUILD_LDFLAGS):' \
+ -e 's:@CC@:$(CC_FOR_BUILD):' \
+ docs/Makefile.in || die
+}
+
+src_configure() {
+ if ! use latex; then
+ sed -i -e '/SUBDIRS/s/LaTeX//' share/Makefile.in || die
+ fi
+
+ use wxwidgets && setup-wxwidgets
+
+ tc-export CC CXX #453174
+ tc-export_build_env BUILD_CC
+ export CC_FOR_BUILD=${BUILD_CC}
+
+ econf \
+ --with-texdir="${TEXMF}/tex/latex/${PN}" \
+ --with-readline=$(usex readline gnu builtin) \
+ $(use_with amos) \
+ $(use_with bitmap bitmap-terminals) \
+ $(use_with cairo) \
+ $(use_with gd) \
+ $(use_with gpic) \
+ "$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
+ $(use_with libcerf) \
+ $(use_with lua) \
+ $(use_with metafont) \
+ $(use_with metapost) \
+ $(use_with qt6 qt qt6) \
+ $(use_with regis) \
+ $(use_with tgif) \
+ $(use_with X x) \
+ --enable-stats \
+ $(use_enable wxwidgets) \
+ DIST_CONTACT="https://bugs.gentoo.org/" \
+ EMACS=no
+}
+
+src_compile() {
+ # Prevent access violations, see bug 201871
+ export VARTEXFONTS="${T}/fonts"
+
+ emake all
+
+ # pdflatex fails in titlepag.tex: "Argument of  has an extra }."
+ # Install the pre-built gnuplot.pdf instead.
+ #if use doc; then
+ # if use cairo; then
+ # emake -C docs pdf
+ # else
+ # ewarn "Cannot build figures unless cairo is enabled."
+ # ewarn "Building documentation without figures."
+ # emake -C docs pdf_nofig
+ # mv docs/nofigures.pdf docs/gnuplot.pdf || die
+ # fi
+ #fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc BUGS NEWS PGPKEYS README* RELEASE_NOTES
+ newdoc term/PostScript/README README-ps
+ newdoc term/js/README README-js
+ use lua && newdoc term/lua/README README-lua
+
+ local DOC_CONTENTS='Gnuplot no longer links against pdflib. You can
+ use the "pdfcairo" terminal for PDF output.'
+ use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
+ use gd && DOC_CONTENTS+="\n\nFor font support in png/jpeg/gif output,
+ you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
+ environment variables. See the FAQ file in /usr/share/doc/${PF}/
+ for more information."
+ readme.gentoo_create_doc
+
+ if use examples; then
+ # Demo files
+ insinto /usr/share/${PN}/${GP_VERSION}
+ doins -r demo
+ rm "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/binary{1,2,3} || die
+ rm "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/plugin/*.{o,so} || die
+ fi
+
+ if use doc; then
+ # Manual, FAQ
+ dodoc docs/gnuplot.pdf #FAQ.pdf
+ # Documentation for making PostScript files
+ docinto psdoc
+ dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
+ fi
+}
+
+src_test() {
+ emake check GNUTERM="dumb"
+}
+
+pkg_postinst() {
+ use latex && texmf-update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ use latex && texmf-update
+}