summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2018-01-01 21:49:25 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-03 12:06:39 +0100
commit71ebde04f264ef5e49f04701791ef415e65e361e (patch)
tree4692f6901377b7dc755cf8903d47fd9c2614e0d3 /sys-apps/bleachbit
parentmedia-sound/aacgain: stable fix (diff)
downloadgentoo-71ebde04f264ef5e49f04701791ef415e65e361e.tar.gz
gentoo-71ebde04f264ef5e49f04701791ef415e65e361e.tar.bz2
gentoo-71ebde04f264ef5e49f04701791ef415e65e361e.zip
sys-apps/bleachbit: drop dev-pythonnotify-python from RDEPEND and add elog message.
dev-python/notify-python is optional and not necessary in many if not most use cases. Hence, just like in e.g. Debian, it should not be a hard dependency. Moreover, it unconditionally pulls in dev-python/pygtk, rendering the gtk USE flag pointless. Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6682
Diffstat (limited to 'sys-apps/bleachbit')
-rw-r--r--sys-apps/bleachbit/bleachbit-1.19-r1.ebuild (renamed from sys-apps/bleachbit/bleachbit-1.19.ebuild)12
1 files changed, 8 insertions, 4 deletions
diff --git a/sys-apps/bleachbit/bleachbit-1.19.ebuild b/sys-apps/bleachbit/bleachbit-1.19-r1.ebuild
index f6f51d048670..6e9674128119 100644
--- a/sys-apps/bleachbit/bleachbit-1.19.ebuild
+++ b/sys-apps/bleachbit/bleachbit-1.19-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,9 +21,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+gtk nls"
-RDEPEND="
- dev-python/notify-python[$PYTHON_USEDEP]
- gtk? ( dev-python/pygtk:2[$PYTHON_USEDEP] )"
+RDEPEND="gtk? ( dev-python/pygtk:2[$PYTHON_USEDEP] )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -64,3 +62,9 @@ python_install_all() {
doicon ${PN}.png
domenu ${PN}.desktop
}
+
+pkg_postinst() {
+ elog "Bleachbit has optional notification support. To enable, please install:"
+ elog ""
+ elog " dev-python/notify-python"
+}