summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-09-23 00:33:31 +0800
committerJason Zaman <perfinion@gentoo.org>2017-09-23 10:13:34 +0800
commit3732da9b0ff333d07a6fd8c7e7bffe3d3fa177a9 (patch)
treeaec46784de6cbc66bacb3b39f2f487e6e1dbb072 /sys-apps/checkpolicy/checkpolicy-2.7_rc1.ebuild
parentsys-apps/semodule-utils: drop old (diff)
downloadgentoo-3732da9b0ff333d07a6fd8c7e7bffe3d3fa177a9.tar.gz
gentoo-3732da9b0ff333d07a6fd8c7e7bffe3d3fa177a9.tar.bz2
gentoo-3732da9b0ff333d07a6fd8c7e7bffe3d3fa177a9.zip
sys-apps/checkpolicy: drop old
Package-Manager: Portage-2.3.8, Repoman-2.3.1
Diffstat (limited to 'sys-apps/checkpolicy/checkpolicy-2.7_rc1.ebuild')
-rw-r--r--sys-apps/checkpolicy/checkpolicy-2.7_rc1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/sys-apps/checkpolicy/checkpolicy-2.7_rc1.ebuild b/sys-apps/checkpolicy/checkpolicy-2.7_rc1.ebuild
deleted file mode 100644
index b9745272e577..000000000000
--- a/sys-apps/checkpolicy/checkpolicy-2.7_rc1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit toolchain-funcs
-
-MY_P="${P//_/-}"
-MY_RELEASEDATE="20170609"
-
-SEPOL_VER="${PV}"
-SEMNG_VER="${PV}"
-
-DESCRIPTION="SELinux policy compiler"
-HOMEPAGE="http://userspace.selinuxproject.org"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN}"
-else
- SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug"
-
-DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
- >=sys-libs/libsemanage-${SEMNG_VER}
- sys-devel/flex
- sys-devel/bison"
-
-RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- YACC="bison -y" \
- LIBDIR="\$(PREFIX)/$(get_libdir)"
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \
- install
-
- if use debug; then
- dobin "${S}/test/dismod"
- dobin "${S}/test/dispol"
- fi
-}
-
-pkg_postinst() {
- einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
-}