summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-06-03 09:30:42 -0400
committerKenton Groombridge <concord@gentoo.org>2022-06-03 21:03:11 -0400
commit6ad08222c816246060a8d87a8d2a5f5f9fc84a6b (patch)
tree1b221c69535a4b594802edd9aa82d0fe7ceb66b9 /sys-apps/checkpolicy
parentsys-libs/libsemanage: bump to 3.4 (diff)
downloadgentoo-6ad08222c816246060a8d87a8d2a5f5f9fc84a6b.tar.gz
gentoo-6ad08222c816246060a8d87a8d2a5f5f9fc84a6b.tar.bz2
gentoo-6ad08222c816246060a8d87a8d2a5f5f9fc84a6b.zip
sys-apps/checkpolicy: bump to 3.4
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-apps/checkpolicy')
-rw-r--r--sys-apps/checkpolicy/Manifest1
-rw-r--r--sys-apps/checkpolicy/checkpolicy-3.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/checkpolicy/Manifest b/sys-apps/checkpolicy/Manifest
index 1a877520394b..77c838495954 100644
--- a/sys-apps/checkpolicy/Manifest
+++ b/sys-apps/checkpolicy/Manifest
@@ -1,2 +1,3 @@
DIST checkpolicy-3.3.tar.gz 69286 BLAKE2B f22cb1b0dae5a89c0abb500c2f091beda7960493bd0dc3b9cb5bc8d2d08d507870e5db46f53ad87d0ddea5e3bbdb6c721a5c5e6824b37f554049000392af6a6d SHA512 40e7ccd804aa19f229eb76bdaeb79c87ed19004ac7b91674ecfb92d543573dc26f9d456ea25ed1e0ef8e1a69538e41c68b386a0743023f3ea83aa4350fc3ce30
DIST checkpolicy-3.4-rc1.tar.gz 69829 BLAKE2B 7d217c79b689b8d08a4d16b174ac01bbee48ced7cc0920792a7263f3143f77838ba9f75ce7a3919a7eaa5818ac7ebdd1890a5fdc050680e45341bfe06dec634b SHA512 9aac4bd862f6dcb654cdbc786e0f89f8eccf2f93e6368b3d458a4a15210a558552ffeb64be9daf57bf3309bf74661a4eb6a5a336e64357f6e99bf3b7946d9b45
+DIST checkpolicy-3.4.tar.gz 69870 BLAKE2B 891033b1d9d50a3738bb779d014d2f04d6cc5450c6f84ed43246c95b0c808f347d65c0e51c7254041e13b1c555a7e1de5092abb4fc12fabb109be7ddaa090829 SHA512 e7f7a4e987af473fd7cda0e47539061a8cb2e65a6b930f4736c538eb319129b260a3f03d2f50863e73a275ee3d58c441c33f95c80ea2bff6157e37226be54b92
diff --git a/sys-apps/checkpolicy/checkpolicy-3.4.ebuild b/sys-apps/checkpolicy/checkpolicy-3.4.ebuild
new file mode 100644
index 000000000000..b699f09c01de
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-3.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://userspace.selinuxproject.org"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug"
+
+DEPEND=">=sys-libs/libsepol-${PV}"
+BDEPEND="sys-devel/flex
+ sys-devel/bison"
+
+RDEPEND=">=sys-libs/libsepol-${PV}"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ YACC="bison -y" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ default
+
+ if use debug; then
+ dobin "${S}/test/dismod"
+ dobin "${S}/test/dispol"
+ fi
+}
+
+pkg_postinst() {
+ if ! tc-is-cross-compiler; then
+ einfo "This checkpolicy can compile version `checkpolicy -V | cut -f 1 -d ' '` policy."
+ fi
+}