summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-10 15:16:38 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-10 15:17:10 +0200
commit63c7d638e29b992634da12b44015a6b0a71b2aa3 (patch)
tree3881409a7e7d22f6e4c56b242958967b241fbe62 /sys-apps/cpuid
parentapp-emulation/pcem: drop old version (diff)
downloadgentoo-63c7d638e29b992634da12b44015a6b0a71b2aa3.tar.gz
gentoo-63c7d638e29b992634da12b44015a6b0a71b2aa3.tar.bz2
gentoo-63c7d638e29b992634da12b44015a6b0a71b2aa3.zip
sys-apps/cpuid: bump to version 20201006
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20201006.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index bbd8bf9e72d7..80ef1cdbb22a 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1 +1,2 @@
DIST cpuid-20200427.src.tar.gz 115896 BLAKE2B 0c325fe140ffb9e9d1591d414156d280ac6e802eb652f876fcb6888ea4d6cefd485bc6501179a4f7f3db33ca0fe9f64b83214f883b86bda0c8014b81916d893c SHA512 8f943ac517680c8744563f35654f5b5201fde16cfe24264d8ad171ab517b65a6f50dc569789228e095e2b485e5a0d4fe58e2a0d7f199df2b225652689e3a2e83
+DIST cpuid-20201006.src.tar.gz 118994 BLAKE2B 05c547858358a92b0c9270066dc33e08693922e4ba765edcba7aca201811c54074a0cd683edb3e9dedf2bb0fd23682b3cc5725e4067b27ec27e0fe979eb22f56 SHA512 f037c1707b49e92f1bd605ec87a0995ae36215d075bcbadfed1d11f5fefda43391b48f10d2517334574aa7e243f0b73d22f1fcbfe1fb133aaf5bad1046e8ba5e
diff --git a/sys-apps/cpuid/cpuid-20201006.ebuild b/sys-apps/cpuid/cpuid-20201006.ebuild
new file mode 100644
index 000000000000..c48d21a156d2
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20201006.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-lang/perl"
+DEPEND="app-arch/gzip"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20200203-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}