summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-27 23:38:49 +0100
committerSam James <sam@gentoo.org>2022-03-27 23:40:46 +0100
commit74020795b5786fd4963fdd1823c2aa302273a3c5 (patch)
tree2957fff82f983a1289e06a1e6028c9682bbb8167 /sys-apps/dbus
parentnet-print/cups-filters: drop 1.28.3-r1, 1.28.8-r1, 1.28.9-r1, 1.28.10-r2 (diff)
downloadgentoo-74020795b5786fd4963fdd1823c2aa302273a3c5.tar.gz
gentoo-74020795b5786fd4963fdd1823c2aa302273a3c5.tar.bz2
gentoo-74020795b5786fd4963fdd1823c2aa302273a3c5.zip
sys-apps/dbus: add 1.14.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/Manifest1
-rw-r--r--sys-apps/dbus/dbus-1.14.0.ebuild287
-rw-r--r--sys-apps/dbus/files/dbus-1.14.0-x-autoconf-fixes.patch147
3 files changed, 435 insertions, 0 deletions
diff --git a/sys-apps/dbus/Manifest b/sys-apps/dbus/Manifest
index e530cbf7268b..19ec71675e81 100644
--- a/sys-apps/dbus/Manifest
+++ b/sys-apps/dbus/Manifest
@@ -1,2 +1,3 @@
DIST dbus-1.12.20.tar.gz 2095511 BLAKE2B b467526e7e0281db7b8c7c178469fe006dab29ccb1ea197c02495bd297e8de766230b68ed86c4a7e05dbe09ca30ce941a15e0bf8030fe0df66c04febf0534b3b SHA512 0964683bc6859374cc94e42e1ec0cdb542cca67971c205fcba4352500b6c0891665b0718e7d85eb060c81cb82e3346c313892bc02384da300ddd306c7eef0056
DIST dbus-1.12.22.tar.gz 2108231 BLAKE2B 40c30ad9e48d8ac6b5f1c67726015eb17cb3501372ef2c8ffcd8ad73e4a2f186b80a7bbba094460d4093d1d0a3f1bbb8d83a27724397a8f5312bb8542237e6b7 SHA512 0a716022f9d693fcaf871b6dfb5f242b49a8dd05d3316ec3e530f5129f1d81a2fa9caec795fa62cfdcba6ed21549fdd2f896f9bf1cc9a96e2a7d04f2c7ec7be6
+DIST dbus-1.14.0.tar.xz 1360228 BLAKE2B ae0ebc2779e840e2d83f633029f81fba0e35969648dddce0280640dd9bee3f9508aa7fb6aef696d1c4c56d40f91b754941f847525afaee5cc3170ad23a7eddbf SHA512 9bf17a3ebb3cf44722c6fbf24ee56e9dc14d6882fc312f26c7f07459d969424bc2fb63a229139e011804ecc479a8f0eb1a0c83286f8d5a664c5979d12634179f
diff --git a/sys-apps/dbus/dbus-1.14.0.ebuild b/sys-apps/dbus/dbus-1.14.0.ebuild
new file mode 100644
index 000000000000..03e772f142c6
--- /dev/null
+++ b/sys-apps/dbus/dbus-1.14.0.ebuild
@@ -0,0 +1,287 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+TMPFILES_OPTIONAL=1
+
+# At least at the moment, while a CMake port exists, it's not recommended
+# for distributions.
+# https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/CONTRIBUTING.md#L189
+inherit autotools flag-o-matic linux-info python-any-r1 readme.gentoo-r1 systemd tmpfiles virtualx multilib-minimal
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/dbus/"
+SRC_URI="https://dbus.freedesktop.org/releases/dbus/${P}.tar.xz"
+
+LICENSE="|| ( AFL-2.1 GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc elogind selinux static-libs systemd test X"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+BDEPEND="
+ acct-user/messagebus
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.4
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+COMMON_DEPEND="
+ >=dev-libs/expat-2.1.0
+ elogind? ( sys-auth/elogind )
+ selinux? ( sys-libs/libselinux )
+ systemd? ( sys-apps/systemd:0= )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/expat
+ test? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.40:2
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ acct-user/messagebus
+ selinux? ( sec-policy/selinux-dbus )
+ systemd? ( virtual/tmpfiles )
+"
+
+DOC_CONTENTS="
+ Some applications require a session bus in addition to the system
+ bus. Please see \`man dbus-launch\` for more information.
+"
+
+# out of sources build dir for make check
+TBD="${WORKDIR}/${P}-tests-build"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-enable-elogind.patch"
+ "${FILESDIR}/${PN}-daemon-optional.patch" # bug #653136
+
+ "${FILESDIR}/${P}-x-autoconf-fixes.patch"
+)
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+
+ if use kernel_linux; then
+ CONFIG_CHECK="~EPOLL"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-solaris* ]]; then
+ # fix standards conflict, due to gcc being c99 by default nowadays
+ sed -i \
+ -e 's/_XOPEN_SOURCE=500/_XOPEN_SOURCE=600/' \
+ configure.ac || die
+ fi
+
+ # required for bug #263909, cross-compile so don't remove eautoreconf
+ eautoreconf
+}
+
+src_configure() {
+ local rundir=$(usex kernel_linux /run /var/run)
+
+ sed -e "s;@rundir@;${EPREFIX}${rundir};g" "${FILESDIR}"/dbus.initd.in \
+ > "${T}"/dbus.initd || die
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local docconf myconf testconf
+
+ # so we can get backtraces from apps
+ case ${CHOST} in
+ *-mingw*)
+ # error: unrecognized command line option '-rdynamic', bug #488036
+ ;;
+ *)
+ append-flags -rdynamic
+ ;;
+ esac
+
+ # libaudit is *only* used in DBus wrt SELinux support, so disable it, if
+ # not on an SELinux profile.
+ myconf=(
+ --localstatedir="${EPREFIX}/var"
+ $(use_enable static-libs static)
+ $(use_enable debug verbose-mode)
+ --disable-asserts
+ --disable-checks
+ $(use_enable selinux)
+ $(use_enable selinux libaudit)
+ --disable-apparmor
+ $(use_enable kernel_linux inotify)
+ --disable-kqueue
+ $(use_enable elogind)
+ $(use_enable systemd)
+ $(use_enable systemd user-session)
+ --disable-embedded-tests
+ --disable-modular-tests
+ $(use_enable debug stats)
+ --with-session-socket-dir="${EPREFIX}"/tmp
+ --with-system-pid-file="${EPREFIX}${rundir}"/dbus.pid
+ --with-system-socket="${EPREFIX}${rundir}"/dbus/system_bus_socket
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ --with-dbus-user=messagebus
+ $(use_with X x)
+ )
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ myconf+=(
+ --enable-launchd
+ --with-launchd-agent-dir="${EPREFIX}"/Library/LaunchAgents
+ )
+ fi
+
+ if multilib_is_native_abi; then
+ docconf=(
+ --enable-xml-docs
+ $(use_enable doc doxygen-docs)
+ )
+ else
+ docconf=(
+ --disable-xml-docs
+ --disable-doxygen-docs
+ )
+ myconf+=(
+ --disable-daemon
+ --disable-selinux
+ --disable-libaudit
+ --disable-elogind
+ --disable-systemd
+ --without-x
+ )
+ fi
+
+ einfo "Running configure in ${BUILD_DIR}"
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" "${docconf[@]}"
+
+ if multilib_is_native_abi && use test; then
+ mkdir "${TBD}" || die
+ cd "${TBD}" || die
+ testconf=(
+ $(use_enable test asserts)
+ $(use_enable test checks)
+ $(use_enable test embedded-tests)
+ $(use_enable test stats)
+ $(has_version dev-libs/dbus-glib && echo --enable-modular-tests)
+ )
+ einfo "Running configure in ${TBD}"
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" "${testconf[@]}"
+ fi
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ # After the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ einfo "Running make in ${BUILD_DIR}"
+ emake
+
+ if use test; then
+ einfo "Running make in ${TBD}"
+ emake -C "${TBD}"
+ fi
+ else
+ emake -C dbus libdbus-1.la
+ fi
+}
+
+src_test() {
+ # DBUS_TEST_MALLOC_FAILURES=0 to avoid huge test logs
+ # https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/CONTRIBUTING.md#L231
+ DBUS_TEST_MALLOC_FAILURES=0 DBUS_VERBOSE=1 virtx emake -j1 -C "${TBD}" check
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ emake DESTDIR="${D}" install
+ else
+ emake DESTDIR="${D}" install-pkgconfigDATA
+ emake DESTDIR="${D}" -C dbus \
+ install-libLTLIBRARIES install-dbusincludeHEADERS \
+ install-nodist_dbusarchincludeHEADERS
+ fi
+}
+
+multilib_src_install_all() {
+ newinitd "${T}"/dbus.initd dbus
+
+ if use X; then
+ # dbus X session script (bug #77504)
+ # turns out to only work for GDM (and startx). has been merged into
+ # other desktop (kdm and such scripts)
+ exeinto /etc/X11/xinit/xinitrc.d
+ doexe "${FILESDIR}"/80-dbus
+ fi
+
+ # Needs to exist for dbus sessions to launch
+ keepdir /usr/share/dbus-1/services
+ keepdir /etc/dbus-1/{session,system}.d
+ # machine-id symlink from pkg_postinst()
+ keepdir /var/lib/dbus
+ # Let the init script create the /var/run/dbus directory
+ rm -rf "${ED}"/var/run
+
+ # bug #761763
+ rm -rf "${ED}"/usr/lib/sysusers.d
+
+ dodoc AUTHORS NEWS README doc/TODO
+ readme.gentoo_create_doc
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ if use systemd; then
+ tmpfiles_process dbus.conf
+ fi
+
+ # Ensure unique id is generated and put it in /etc wrt bug #370451 but symlink
+ # for DBUS_MACHINE_UUID_FILE (see tools/dbus-launch.c) and reverse
+ # dependencies with hardcoded paths (although the known ones got fixed already)
+ # TODO: should be safe to remove at least the ln because of the above tmpfiles_process?
+ dbus-uuidgen --ensure="${EROOT}"/etc/machine-id
+ ln -sf "${EPREFIX}"/etc/machine-id "${EROOT}"/var/lib/dbus/machine-id
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ local plist="org.freedesktop.dbus-session.plist"
+ elog
+ elog
+ elog "For MacOS/Darwin we now ship launchd support for dbus."
+ elog "This enables autolaunch of dbus at session login and makes"
+ elog "dbus usable under MacOS/Darwin."
+ elog
+ elog "The launchd plist file ${plist} has been"
+ elog "installed in ${EPREFIX}/Library/LaunchAgents."
+ elog "For it to be used, you will have to do all of the following:"
+ elog " + cd ~/Library/LaunchAgents"
+ elog " + ln -s ${EPREFIX}/Library/LaunchAgents/${plist}"
+ elog " + logout and log back in"
+ elog
+ elog "If your application needs a proper DBUS_SESSION_BUS_ADDRESS"
+ elog "specified and refused to start otherwise, then export the"
+ elog "the following to your environment:"
+ elog " DBUS_SESSION_BUS_ADDRESS=\"launchd:env=DBUS_LAUNCHD_SESSION_BUS_SOCKET\""
+ fi
+}
diff --git a/sys-apps/dbus/files/dbus-1.14.0-x-autoconf-fixes.patch b/sys-apps/dbus/files/dbus-1.14.0-x-autoconf-fixes.patch
new file mode 100644
index 000000000000..d9eb2a611bfd
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-1.14.0-x-autoconf-fixes.patch
@@ -0,0 +1,147 @@
+https://gitlab.freedesktop.org/dbus/dbus/-/commit/7d462fe93844df711ff8433ad798b54e57f8609d.patch
+(dropped NEWS to avoid conflicts with more patches in future)
+
+From fdbb32bd1f3c972d3d5fd3998930749206a1095a Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Tue, 1 Mar 2022 15:56:30 +0100
+Subject: [PATCH 1/6] build: Treat --with-x[=yes] the same as --with-x=auto
+
+Previously, --with-x would disable the check for X11 libraries, which
+was not intended.
+
+(cherry picked from commit 99cc28e0eb1a37233c0f7d3595175d1f331550e7)
+--- a/configure.ac
++++ b/configure.ac
+@@ -1115,7 +1115,7 @@ if test "x$dbus_win" = xyes; then
+
+ enable_x11_autolaunch=no
+ have_x11=no
+-else if test "x$with_x" = xauto; then
++else if test "x$with_x" != xno; then
+ PKG_CHECK_MODULES([X], [x11],
+ [AC_DEFINE([HAVE_X11], [1], [Define to 1 if you have X11 library])],
+ [ have_x11=no ])
+GitLab
+From 5f2577aea3c5291dbb97e77c7384924851b30102 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Tue, 1 Mar 2022 16:01:29 +0100
+Subject: [PATCH 2/6] Move DBUS_X_* definitions into PKG_CHECK_MODULES block
+
+(cherry picked from commit 51e468d828785cbc7060678f6f257723ba11cd10)
+--- a/configure.ac
++++ b/configure.ac
+@@ -1117,15 +1117,15 @@ if test "x$dbus_win" = xyes; then
+ have_x11=no
+ else if test "x$with_x" != xno; then
+ PKG_CHECK_MODULES([X], [x11],
+- [AC_DEFINE([HAVE_X11], [1], [Define to 1 if you have X11 library])],
++ [AC_DEFINE([HAVE_X11], [1], [Define to 1 if you have X11 library])
++ have_x11=yes
++ DBUS_X_LIBS="$X_LIBS"
++ DBUS_X_CFLAGS="$X_CFLAGS"
++ ],
+ [ have_x11=no ])
+
+ if test "x$have_x11" = xno; then
+ AC_MSG_WARN([Couldn't found X11, tried with pkg-config.])
+- else
+- have_x11=yes
+- DBUS_X_LIBS="$X_LIBS"
+- DBUS_X_CFLAGS="$X_CFLAGS"
+ fi
+ else
+ AS_IF([test "x$enable_x11_autolaunch" = "xyes"], [
+GitLab
+From 5dad12f34c54e2359adfe8e7f122681df1d24bcb Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Tue, 1 Mar 2022 16:05:52 +0100
+Subject: [PATCH 3/6] Emit an error when --with-x was given but no X11 libs
+ were found
+
+(cherry picked from commit 17c88a894499da64460a0ef76db1d8b88ceb9eeb)
+--- a/configure.ac
++++ b/configure.ac
+@@ -1121,12 +1121,13 @@ else if test "x$with_x" != xno; then
+ have_x11=yes
+ DBUS_X_LIBS="$X_LIBS"
+ DBUS_X_CFLAGS="$X_CFLAGS"
+- ],
+- [ have_x11=no ])
+-
+- if test "x$have_x11" = xno; then
+- AC_MSG_WARN([Couldn't found X11, tried with pkg-config.])
+- fi
++ ], [
++ AS_IF([test "x$with_x" = xyes],
++ [AC_MSG_ERROR([Couldn't find X11, tried with pkg-config.])],
++ [AC_MSG_WARN([Couldn't find X11, tried with pkg-config.])]
++ )
++ have_x11=no
++ ])
+ else
+ AS_IF([test "x$enable_x11_autolaunch" = "xyes"], [
+ AC_MSG_ERROR([--enable-x11-autolaunch and --without-x are not compatible])
+GitLab
+From e03554eb0bf2731e39c06191403f7544df9bb307 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Tue, 1 Mar 2022 16:08:06 +0100
+Subject: [PATCH 4/6] Add have_x11=no if --without-x was given to make later
+ checks happy
+
+(cherry picked from commit bf3cb42c6db1f4479467d66a111b08a98afef31b)
+--- a/configure.ac
++++ b/configure.ac
+@@ -1129,6 +1129,7 @@ else if test "x$with_x" != xno; then
+ have_x11=no
+ ])
+ else
++ have_x11=no
+ AS_IF([test "x$enable_x11_autolaunch" = "xyes"], [
+ AC_MSG_ERROR([--enable-x11-autolaunch and --without-x are not compatible])
+ ])
+GitLab
+From 62361f47f9da2346a9ff9a8c4b4bd4a288dc44d5 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Tue, 1 Mar 2022 16:11:05 +0100
+Subject: [PATCH 5/6] Convert "if" calls to AS_IF macro for the block that
+ handles X11
+
+(cherry picked from commit c71f013a64cd7f6de4c9cf3cf3b236239d713eb1)
+--- a/configure.ac
++++ b/configure.ac
+@@ -1108,14 +1108,14 @@ AC_ARG_ENABLE([x11-autolaunch],
+ AS_HELP_STRING([--enable-x11-autolaunch], [build with X11 auto-launch support]),
+ [], [enable_x11_autolaunch=auto])
+
+-if test "x$dbus_win" = xyes; then
+- if test "x$enable_x11_autolaunch" = xyes; then
++AS_IF([test "x$dbus_win" = xyes], [
++ AS_IF([test "x$enable_x11_autolaunch" = xyes], [
+ AC_MSG_ERROR([X11 auto-launch is not supported on Windows])
+- fi
++ ])
+
+ enable_x11_autolaunch=no
+ have_x11=no
+-else if test "x$with_x" != xno; then
++], [test "x$with_x" != xno], [
+ PKG_CHECK_MODULES([X], [x11],
+ [AC_DEFINE([HAVE_X11], [1], [Define to 1 if you have X11 library])
+ have_x11=yes
+@@ -1128,13 +1128,12 @@ else if test "x$with_x" != xno; then
+ )
+ have_x11=no
+ ])
+-else
++], [
+ have_x11=no
+ AS_IF([test "x$enable_x11_autolaunch" = "xyes"], [
+ AC_MSG_ERROR([--enable-x11-autolaunch and --without-x are not compatible])
+ ])
+-fi
+-fi
++])
+
+ if test "x$enable_x11_autolaunch,$have_x11" = xyes,no; then
+ AC_MSG_ERROR([X11 auto-launch requires X headers/libraries])
+GitLab