summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-13 21:46:24 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-13 21:46:24 -0400
commitd0e05e03f1fbdd25582f6059be896c579e100939 (patch)
treeffb079c778ffb0a218087ecfbcb1d979f0c836d3 /sys-apps/file
parentnet-im/ejabberd: Remove the oldest testing version (diff)
downloadgentoo-d0e05e03f1fbdd25582f6059be896c579e100939.tar.gz
gentoo-d0e05e03f1fbdd25582f6059be896c579e100939.tar.bz2
gentoo-d0e05e03f1fbdd25582f6059be896c579e100939.zip
sys-apps/file: version bump to 5.28
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/Manifest1
-rw-r--r--sys-apps/file/file-5.28.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index 8c054df4481d..c3f5f33b9870 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -2,3 +2,4 @@ DIST file-5.22.tar.gz 732556 SHA256 c4e3a8e44cb888c5e4b476e738503e37fb9de3b25a38
DIST file-5.25.tar.gz 739485 SHA256 3735381563f69fb4239470b8c51b876a80425348b8285a7cded8b61d6b890eca SHA512 4a5176a7e80df2bb7e45916490433d22eb98a442d49d04146afcbdcf92ff619ea3e73e95c8991e6b6a0628efb9d127bfa4aafc1cae523f8261ca693bc5e13402 WHIRLPOOL 70c682ff05e58487a551cd98091e27272baa41e034157bec93ac4d69b2f3e93caed40f37d64ef698527124e86ba4a5cb5975abacfd9eb30e4d3583262e5f0b0b
DIST file-5.26.tar.gz 773061 SHA256 2ef32b4ec936b0ff7b59a021dce56086a716663b6df1138c7ea597d396bf50cf SHA512 e3251dde54f200b6bcade5db97fda25e73efcb2629ff5c464601c82190e12290b89eb942d820d43aa67ef37be3c0f2db00e7e5c303c083e4a8d1c49499b907dd WHIRLPOOL f8922b8cbfe153347f793e34ba7be1c3e36e55800e22fcb675f971bcc2094781a0784d887ece32760e2586fe6c459f56ce605610225f6746dacd70a922ac9e10
DIST file-5.27.tar.gz 774063 SHA256 c2e7d509b1167c4915901ecd257ee924d229a348bf988df6d1934ef0fa34a1a7 SHA512 fcf607d367d85b8a971a62793efc79f7e548e029dd7bb41f95bf992c271c514d70cd4bb5c2ca577e470e0ff1df9dca31beaaf19a5fd4e3f617b36061eff46195 WHIRLPOOL ea7483dce63a4b1f5fa7ee2571e918997bcffb46a7267a1fa45990dc33966e04a22f20d01105b268f6e6ca530a3a9c3f20f4f802a445847c60ee7f943cc5b570
+DIST file-5.28.tar.gz 777859 SHA256 0ecb5e146b8655d1fa84159a847ee619fc102575205a0ff9c6cc60fc5ee2e012 SHA512 42136505e21b14396e3af4e0d3f349687176cf0771d2dc9fed3599a30c7bab59184459f1e51033bce2d6ee0e292eba034bdfda727decca1219c1b3419e6bbfdc WHIRLPOOL f12889fc2a692084989d7029d8b9c849344e4236df8afc9e46c6441712aace5e07fee3bb05267ef76da7d41fbcb6b21db4e3bf6e22af660d43b2edeb6ff1571c
diff --git a/sys-apps/file/file-5.28.ebuild b/sys-apps/file/file-5.28.ebuild
new file mode 100644
index 000000000000..658a92fa32a2
--- /dev/null
+++ b/sys-apps/file/file-5.28.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+DISTUTILS_OPTIONAL=1
+
+inherit eutils distutils-r1 libtool toolchain-funcs multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/glensc/file.git"
+ inherit autotools git-r3
+else
+ SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="http://www.darwinsys.com/file/ http://mx.gw.com/pipermail/file/"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="python static-libs zlib"
+
+DEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}
+ python? ( !dev-python/python-magic )"
+
+src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
+ elibtoolize
+
+ # don't let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ ac_cv_header_zlib_h=$(usex zlib) \
+ ac_cv_lib_z_gzopen=$(usex zlib)
+ econf \
+ --enable-fsect-man5 \
+ $(use_enable static-libs static)
+}
+
+src_configure() {
+ # when cross-compiling, we need to build up our own file
+ # because people often don't keep matching host/target
+ # file versions #362941
+ if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
+ mkdir -p "${WORKDIR}"/build
+ cd "${WORKDIR}"/build
+ tc-export_build_env BUILD_C{C,XX}
+ ECONF_SOURCE=${S} \
+ ac_cv_header_zlib_h=no \
+ ac_cv_lib_z_gzopen=no \
+ CHOST=${CBUILD} \
+ CFLAGS=${BUILD_CFLAGS} \
+ CXXFLAGS=${BUILD_CXXFLAGS} \
+ CPPFLAGS=${BUILD_CPPFLAGS} \
+ LDFLAGS="${BUILD_LDFLAGS} -static" \
+ CC=${BUILD_CC} \
+ CXX=${BUILD_CXX} \
+ econf --disable-shared
+ fi
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi ; then
+ emake
+ else
+ emake -C src libmagic.la
+ fi
+}
+
+src_compile() {
+ if tc-is-cross-compiler && ! ROOT=/ has_version "~${CATEGORY}/${P}" ; then
+ emake -C "${WORKDIR}"/build/src file
+ PATH="${WORKDIR}/build/src:${PATH}"
+ fi
+ multilib-minimal_src_compile
+
+ use python && cd python && distutils-r1_src_compile
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi ; then
+ default
+ else
+ emake -C src install-{includeHEADERS,libLTLIBRARIES} DESTDIR="${D}"
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils-r1_src_install
+ prune_libtool_files
+}