summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-10 12:36:09 +0200
committerMike Gilbert <floppym@gentoo.org>2024-08-12 13:19:12 -0400
commitbf08c86d83872aa12d03b25a432da17e69b236b6 (patch)
tree6d5e94aa7de74e4a7107b448704a1daf6df710f1 /sys-apps/gentoo-systemd-integration
parentsys-apps/gentoo-systemd-integration: unify versions (diff)
downloadgentoo-bf08c86d83872aa12d03b25a432da17e69b236b6.tar.gz
gentoo-bf08c86d83872aa12d03b25a432da17e69b236b6.tar.bz2
gentoo-bf08c86d83872aa12d03b25a432da17e69b236b6.zip
sys-apps/gentoo-systemd-integration: bump EAPI, fix pkgcheck issues
- remove empty IUSE - fix variable order Signed-off-by: Filip Kobierski <fkobi@pm.me> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/gentoo-systemd-integration')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9-r1.ebuild42
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild11
2 files changed, 47 insertions, 6 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9-r1.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9-r1.ebuild
new file mode 100644
index 000000000000..0961e3cf6ebb
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2013-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd udev
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="acct-group/floppy
+ acct-group/usb
+ >=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --with-systemdsystemgeneratordir="$(systemd_get_systemgeneratordir)"
+ --with-systemdsystempresetdir="$(systemd_get_systempresetdir)"
+ udevdir="${EPREFIX}$(get_udevdir)"
+ )
+ econf "${myconf[@]}"
+}
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
index 0023f2d5ed9d..1c92ed516365 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
@@ -1,10 +1,13 @@
-# Copyright 2013-2023 Gentoo Authors
+# Copyright 2013-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd udev
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
inherit autotools git-r3
@@ -13,12 +16,8 @@ else
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
fi
-DESCRIPTION="systemd integration files for Gentoo"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
-
LICENSE="BSD"
SLOT="0"
-IUSE=""
RDEPEND="acct-group/floppy
acct-group/usb