summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-03 05:31:06 +0000
committerSam James <sam@gentoo.org>2022-11-03 06:05:11 +0000
commit33dbff10ac6d8cd37e02acdeea53acd9ec3e7bef (patch)
tree6c737471b667d51df82c431d168180d1d9deed08 /sys-apps/hwdata/hwdata-0.364.ebuild
parentmedia-libs/lcms: add 2.14 (diff)
downloadgentoo-33dbff10ac6d8cd37e02acdeea53acd9ec3e7bef.tar.gz
gentoo-33dbff10ac6d8cd37e02acdeea53acd9ec3e7bef.tar.bz2
gentoo-33dbff10ac6d8cd37e02acdeea53acd9ec3e7bef.zip
sys-apps/hwdata: add 0.364
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/hwdata/hwdata-0.364.ebuild')
-rw-r--r--sys-apps/hwdata/hwdata-0.364.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/hwdata/hwdata-0.364.ebuild b/sys-apps/hwdata/hwdata-0.364.ebuild
new file mode 100644
index 000000000000..9df06b92fe5f
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.364.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+
+ edo "${conf[@]}"
+}