summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-01 08:32:47 +0100
committerSam James <sam@gentoo.org>2022-06-01 08:37:13 +0100
commit7cfee401208ce510484c8e994ecf1a826ff99176 (patch)
treea0a51ba05c2094fc6208e4813587d1324df7ab92 /sys-apps/hwdata
parentdev-libs/nss: Bump to versions 3.68.4 and 3.79 (diff)
downloadgentoo-7cfee401208ce510484c8e994ecf1a826ff99176.tar.gz
gentoo-7cfee401208ce510484c8e994ecf1a826ff99176.tar.bz2
gentoo-7cfee401208ce510484c8e994ecf1a826ff99176.zip
sys-apps/hwdata: add 0.360
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/hwdata')
-rw-r--r--sys-apps/hwdata/Manifest1
-rw-r--r--sys-apps/hwdata/hwdata-0.360.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/hwdata/Manifest b/sys-apps/hwdata/Manifest
index 3a3f2c448ba4..4a195991a142 100644
--- a/sys-apps/hwdata/Manifest
+++ b/sys-apps/hwdata/Manifest
@@ -2,3 +2,4 @@ DIST hwdata-0.354.tar.gz 2212834 BLAKE2B 5df04fd6069e131be7195b515f4f7273e28030d
DIST hwdata-0.357.tar.gz 2234392 BLAKE2B 54f26384664cc78d99db52cffa99bf74f57bf355908bd0a87bd01436596b8ed618567caa6f4486e32cbf11bd9313946db2f4d52ce7f2eae1d25b643e68714473 SHA512 7674e77887629e57cf1d6cb73ce7f4734f9dd5e5f8cee0016aa74f0ff6b962f9f0e501069f4cbaa0a5281fed179d2912a653071999b9f7d0eb4d81fff719cad1
DIST hwdata-0.358.tar.gz 2240851 BLAKE2B b164c267a6779fec2a4018fb8bad98e564794e46cdec77b6f1234444f0fb20f49f44303a400d3301b40b07cebe0cc590553ae5e01702032b53180826273eb416 SHA512 52c765786aa41551e47bad2358bbe50f8f6a60cd820696c6c341f08cbde695f86746660a3fdadd8fad5614b99a98616111011a17d115c25bbcaf03c891cc3e69
DIST hwdata-0.359.tar.gz 2247837 BLAKE2B af573e38cc04281e18e202fe134430cca3f85129196ff793571f1aa12c2380719e470941e4c8ab74cc888b5f06498d70af2ac1604e758b77f329e11043aae4c0 SHA512 e3054ded9ff913498f27206829af91cfd816acc0cb574f85207f6df5568502c28ff9d4a778549c900e90dcc8958deb45a1eb1511bae57b3240472402576b4943
+DIST hwdata-0.360.tar.gz 2254316 BLAKE2B c2fae537f2ff594f73577cf72af9d6201bcd1dc26059786c1ae8cb7999d3774306244ea10aee0f9b4916f4a7547b549ccbd815ca9a93053e6ca069140e3a7232 SHA512 dc04bdfc21a7bb9903cc51156c9bf1f0d6c7c772db1a47f9d5b120e1e4955155fb5057ccc6679ae56ac790e5da3ca719a3a9b9cd9082eac261ef11e75c97a244
diff --git a/sys-apps/hwdata/hwdata-0.360.ebuild b/sys-apps/hwdata/hwdata-0.360.ebuild
new file mode 100644
index 000000000000..81b4b0771008
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.360.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+ echo "${conf[@]}" >&2
+ "${conf[@]}" || die
+}