summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-03-01 18:15:12 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-03-01 18:20:41 +0100
commit13b6f378ac4f9a8c5546e160a3dc3a8a9ead5036 (patch)
tree3b867079094cd71bb770193ac7656985248edb73 /sys-apps/irqbalance/irqbalance-1.2.0.ebuild
parentnet-dns/dnsmasq: add support dhcp_release6, needed for openstack ocata (diff)
downloadgentoo-13b6f378ac4f9a8c5546e160a3dc3a8a9ead5036.tar.gz
gentoo-13b6f378ac4f9a8c5546e160a3dc3a8a9ead5036.tar.bz2
gentoo-13b6f378ac4f9a8c5546e160a3dc3a8a9ead5036.zip
sys-apps/irqbalance: Bump to version 1.2.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-apps/irqbalance/irqbalance-1.2.0.ebuild')
-rw-r--r--sys-apps/irqbalance/irqbalance-1.2.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/irqbalance/irqbalance-1.2.0.ebuild b/sys-apps/irqbalance/irqbalance-1.2.0.ebuild
new file mode 100644
index 000000000000..5a860709ee8d
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils systemd linux-info
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="https://github.com/Irqbalance/irqbalance"
+SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="caps +numa selinux"
+
+CDEPEND="
+ dev-libs/glib:2
+ sys-libs/ncurses:0=[unicode]
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-irqbalance )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-tinfo.patch"
+)
+
+pkg_setup() {
+ CONFIG_CHECK="~PCI_MSI"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ # Follow systemd policies
+ # https://wiki.gentoo.org/wiki/Project:Systemd/Ebuild_policy
+ sed \
+ -e 's/ $IRQBALANCE_ARGS//' \
+ -e '/EnvironmentFile/d' \
+ -i misc/irqbalance.service || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with caps libcap-ng)
+ $(use_enable numa)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newinitd "${FILESDIR}"/irqbalance.init.4 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_dounit misc/irqbalance.service
+}