summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-14 08:35:20 +0000
committerSam James <sam@gentoo.org>2023-12-14 08:35:20 +0000
commitc8d1b92853982c1b36619a033cb404f08ee462a0 (patch)
tree754b174c675ac0af86e8088c82d31410edabbc3e /sys-apps/moar
parentsys-apps/moar: drop 1.18.3, 1.18.4 (diff)
downloadgentoo-c8d1b92853982c1b36619a033cb404f08ee462a0.tar.gz
gentoo-c8d1b92853982c1b36619a033cb404f08ee462a0.tar.bz2
gentoo-c8d1b92853982c1b36619a033cb404f08ee462a0.zip
sys-apps/moar: add 1.18.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.18.6.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index 756a1b1e292a..10124e770d43 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -1,2 +1,4 @@
DIST moar-1.18.5-deps.tar.xz 4893264 BLAKE2B 48ac9d4992c2f6d1aa0f9160bde87bd19d66acfe912753645c9dbb6e5bc007eb68caf1fff53bae84b03e4a6607858717666b1527bf8d0080b0aca6dbb37a894e SHA512 bf141777d4fee5c14e76130671862f255675da3c628c21cb892d53a469a0872d4c7f47699c16c50728df76ba4d9e467e9b8744a322c1acc8d0151f9eb5987b66
DIST moar-1.18.5.tar.gz 2786493 BLAKE2B dc8e47fd59cb485d7b105428053015221b280753838d5a21c140df49b51aebea7befa14ba4549f89019956c1df2cf9bf5ffeab458fa99f483f353dcb63100bd6 SHA512 c7efc790d6a8b0867a0e8c5734b95e03b6deed3627f9278b7a7e8086cf4313322d87ac98e34ec1777f9a01b0dddac894737d09c1c20aaed1fa2b2b47a370d59d
+DIST moar-1.18.6-deps.tar.xz 4893264 BLAKE2B 48ac9d4992c2f6d1aa0f9160bde87bd19d66acfe912753645c9dbb6e5bc007eb68caf1fff53bae84b03e4a6607858717666b1527bf8d0080b0aca6dbb37a894e SHA512 bf141777d4fee5c14e76130671862f255675da3c628c21cb892d53a469a0872d4c7f47699c16c50728df76ba4d9e467e9b8744a322c1acc8d0151f9eb5987b66
+DIST moar-1.18.6.tar.gz 2786730 BLAKE2B 0c78fd8833a14141eecc246a0db71ec418cfd0552761ca71616620137e2eb44e173528e78da138707be19e3da76b7d9cf3bec73866c989b566d10ae8b20296e9 SHA512 9dd0972a7b2c77b8cf9eb4c927e95e5b85e1e10c0892a41d208c452c86951573a8f7d9919d467d7eae96581940e07d60e2f84a04c06347484a24c98f8307e8ca
diff --git a/sys-apps/moar/moar-1.18.6.ebuild b/sys-apps/moar/moar-1.18.6.ebuild
new file mode 100644
index 000000000000..25abd2aac1ff
--- /dev/null
+++ b/sys-apps/moar/moar-1.18.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}