summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/netloc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/netloc')
-rw-r--r--sys-apps/netloc/Manifest1
-rw-r--r--sys-apps/netloc/metadata.xml8
-rw-r--r--sys-apps/netloc/netloc-0.5.ebuild29
3 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/netloc/Manifest b/sys-apps/netloc/Manifest
new file mode 100644
index 000000000000..3d0b16f4d4ef
--- /dev/null
+++ b/sys-apps/netloc/Manifest
@@ -0,0 +1 @@
+DIST netloc-0.5.tar.gz 474646 SHA256 41a8d31097b9aeabff89596b42bd3d4590f6b7552378a0fc80ec7a02823c5d1a SHA512 88600c59302cd8e5ed024373a57b27e54b288288091ed0ab3852bee59c255a8b520d38c59d64f6c1eafe307f0d5e61d64c799a92e9695c42ecc1e33dcc2df6ba WHIRLPOOL d83dbe17bcea2c083ded5c364e344b904799fd6405a38e52318d9d88f041ee47b50383fd038003b2e558b36577544779c118c509de29cc1e2027314cf3b8b8b1
diff --git a/sys-apps/netloc/metadata.xml b/sys-apps/netloc/metadata.xml
new file mode 100644
index 000000000000..91d88c8a551c
--- /dev/null
+++ b/sys-apps/netloc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cluster</herd>
+<longdescription>
+ The Portable Network Locality (netloc) software package provides network topology discovery tools, and an abstract representation of those networks topologies for a range of network types and configurations. It is provided as a companion to the Portable Hardware Locality (hwloc) package. These two software packages work together to provide a comprehensive view of the HPC system topology, spanning from the processor cores in one server to the cores in another – including the complex network(s) in between.
+</longdescription>
+</pkgmetadata>
diff --git a/sys-apps/netloc/netloc-0.5.ebuild b/sys-apps/netloc/netloc-0.5.ebuild
new file mode 100644
index 000000000000..8334b28a948d
--- /dev/null
+++ b/sys-apps/netloc/netloc-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib versionator
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="Portable Network Locality (netloc)"
+HOMEPAGE="http://www.open-mpi.org/projects/netloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/jansson
+ sys-apps/hwloc"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --with-jansson="${EPREFIX}/usr" \
+ --with-hwloc="${EPREFIX}/usr"
+}