summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-14 10:25:09 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-14 10:45:17 +0200
commite4b8a7de4d3c7abdfb7f712e31740afe65804a2f (patch)
treede1fb9b9f6065fc6c8afb1d021eabd79d6c70980 /sys-apps/pkgcore
parentmedia-video/yle-dl: drop 20210704 (diff)
downloadgentoo-e4b8a7de4d3c7abdfb7f712e31740afe65804a2f.tar.gz
gentoo-e4b8a7de4d3c7abdfb7f712e31740afe65804a2f.tar.bz2
gentoo-e4b8a7de4d3c7abdfb7f712e31740afe65804a2f.zip
sys-apps/pkgcore: Bump to 0.12.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/pkgcore')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index 71d22731ad64..3f84c5faa92a 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -3,3 +3,4 @@ DIST pkgcore-0.11.8.tar.gz 631665 BLAKE2B 1e33ce394c1df9418d22fc8653fca4da1b4e27
DIST pkgcore-0.12.0.tar.gz 621376 BLAKE2B d58390ad7251fc48465d744a0b0694210d1f1cf505b072c06dc9731819b327b1edfa60d0f89db113852c87109c6340c8c13c72ae2d89b517d5fca34b53632b6b SHA512 d066a2f2deb4f654b04f9e78d37bf88a97f67f0396f5867ffe3a18f8c0d6459d73721b66cad52a50581ee10420694a1fd195b28a013b3a97cb1ebf08bc59598b
DIST pkgcore-0.12.1.tar.gz 621918 BLAKE2B aa3bedaf4d58d8e604b19ce3e6f97242d29eadbbeab85b7de029d0230a5ea77e2ee96b128381964afe92a327674d64878f833d8c1ddc983c0fe1381b008e2d62 SHA512 a78f3ffd5610f14adb07e2adce07c8446012e742c777d08bbc7ac711bf194508d66a14d21aa56f5d0c9353bd10354fdd34bc6eb4b6017c03bff5d1b565a53575
DIST pkgcore-0.12.2.tar.gz 621604 BLAKE2B 15964d9a73727028010b7267a61802566aa59f28769f4ac67aa91ccd32708b1a27914ba14957e1da848dc1a2a24ee9fbf92a7b4cee055a7cff22dd1f0d204f58 SHA512 192532dcee696e7ce159efad2f90597aa68801759ceb5ae85484a99a11242c1da98b73290ce1e4c9e29f2c92607989991b3802c4d0fb9bd1f4a866dd80f13cde
+DIST pkgcore-0.12.3.tar.gz 621912 BLAKE2B 629c42b9d0236196d018302b0941d05d36d15d2bdf31f51ef0d212ab0aad2968ff58aa938d22ff8ba65d115e5a1e80e0f444959c2c63aa227f34bd2da3868165 SHA512 6942d13aecfbf0af2969b71b92fcf4e8e938c367fe61e4a748cae14eeeb4ba831b7ac50deb04f4afa8a7f1a6dc31a893ce4106e54b188ff0a1036f7afd6798a4
diff --git a/sys-apps/pkgcore/pkgcore-0.12.3.ebuild b/sys-apps/pkgcore/pkgcore-0.12.3.ebuild
new file mode 100644
index 000000000000..5c7eeb03645d
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ dev-python/lxml[${PYTHON_USEDEP}]"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.9.6[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_test() {
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}