summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r5.ebuild')
-rw-r--r--sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r5.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r5.ebuild b/sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r5.ebuild
new file mode 100644
index 000000000000..9591c27b5934
--- /dev/null
+++ b/sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit prefix
+
+DESCRIPTION="Chained EPREFIX utilities and wrappers"
+HOMEPAGE="http://dev.gentoo.org/~mduft"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~ppc-aix ~ia64-hpux ~x86-interix ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-devel/gcc-config"
+
+src_install() {
+ cp "${FILESDIR}"/*.in "${T}"
+ eprefixify "${T}"/*.in
+
+ for x in "${T}"/*.in; do
+ mv ${x} ${x%.in}
+ done
+
+ # install toolchain wrapper.
+ wrapperdir=/usr/${CHOST}/gcc-bin/${CHOST}-prefix-chain-wrapper/${PV}
+ wrappercfg=${CHOST}-prefix-chain-wrapper-${PV}
+
+ exeinto $wrapperdir
+ sed -i -e "s,@GENTOO_PORTAGE_CHOST@,${CHOST},g" "${T}"/prefix-chain-wrapper
+ doexe "${T}"/prefix-chain-wrapper
+
+ dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-gcc
+ dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-g++
+ dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-cpp
+ dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-c++
+
+ dosym $wrapperdir/${CHOST}-gcc $wrapperdir/gcc
+ dosym $wrapperdir/${CHOST}-g++ $wrapperdir/g++
+ dosym $wrapperdir/${CHOST}-cpp $wrapperdir/cpp
+ dosym $wrapperdir/${CHOST}-c++ $wrapperdir/c++
+
+ # LDPATH is required to keep gcc-config happy :(
+ cat > "${T}"/$wrappercfg <<EOF
+GCC_PATH="${EPREFIX}/$wrapperdir"
+LDPATH="${EPREFIX}/$wrapperdir"
+EOF
+
+ insinto /etc/env.d/gcc
+ doins "${T}"/$wrappercfg
+
+ # install startprefix script.
+ exeinto /
+ doexe "${T}"/startprefix
+}