summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-11-29 18:30:45 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-02 22:49:22 +0800
commitf3099add28d9079bc2c8c12dffd23ae5d79854bc (patch)
tree4505bea314bacda5e32fcadf4ce603e4fc77f92c /sys-apps/semodule-utils
parentsys-apps/selinux-python: bump to 3.0_rc2 (diff)
downloadgentoo-f3099add28d9079bc2c8c12dffd23ae5d79854bc.tar.gz
gentoo-f3099add28d9079bc2c8c12dffd23ae5d79854bc.tar.bz2
gentoo-f3099add28d9079bc2c8c12dffd23ae5d79854bc.zip
sys-apps/semodule-utils: bump to 3.0_rc2
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/semodule-utils')
-rw-r--r--sys-apps/semodule-utils/Manifest1
-rw-r--r--sys-apps/semodule-utils/semodule-utils-3.0_rc2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/semodule-utils/Manifest b/sys-apps/semodule-utils/Manifest
index f3b138fa0927..0b6571bde3e1 100644
--- a/sys-apps/semodule-utils/Manifest
+++ b/sys-apps/semodule-utils/Manifest
@@ -1,2 +1,3 @@
DIST semodule-utils-2.8.tar.gz 12536 BLAKE2B 93a2f8fee887eba72b009071549a687fe86045344979e31493b3f17041ddf3f31c29ea3c754a31f6029847798dfe26d63b02fadc1042bc68aa414050b283d208 SHA512 13d79a22115f5448dafc5202dc3dec66b9ad826051d61d7c126defe823407959511db35713d97c7dfe9e79de96193fec91a10b98c13743e06a1213f5734f4ae7
DIST semodule-utils-2.9.tar.gz 14259 BLAKE2B f72630c520504596171ac6f678b1fde2bb8482b620f0d8f6374c59b85d634ee8c407e3e4b268dae4d6cecfa2749b26f8808dd56f7c5391e7d1ba11f4a8a789e5 SHA512 688f1fcb34042b837019302debda76847691657709130b99bf937a85774a0ae69d789ee82b0633a4d2dc661dc6d0a1706a878ac681317df2abe68418bec3f952
+DIST semodule-utils-3.0-rc2.tar.gz 14269 BLAKE2B 161b0c62045f199bb1acef83fde138307b8095681a2da0a995a42d89e87bb6a0319067d18cd340da354a9ae764b2fa5704b48b0c972ec11df0d9ea6960a71641 SHA512 2f4fd71a255bd03d1fb3b341d96192058005634fcfdd9d07611f4bfec80d4b3e3a033cf1ad9223dd9e2c6fe6708910de021652e577e3ca1ff51997e0147b3413
diff --git a/sys-apps/semodule-utils/semodule-utils-3.0_rc2.ebuild b/sys-apps/semodule-utils/semodule-utils-3.0_rc2.ebuild
new file mode 100644
index 000000000000..73361dcfa657
--- /dev/null
+++ b/sys-apps/semodule-utils/semodule-utils-3.0_rc2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20191122"
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="SELinux policy module utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ install
+}