summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2019-04-25 09:10:57 +0200
committerMichael Haubenwallner <haubi@gentoo.org>2019-04-25 09:16:53 +0200
commit28ab1487a7154b816aa261c3118c148c7fa6f6bf (patch)
treec7a6f374af7a6490b9831ad15080dad5874e675d /sys-apps
parentwww-apps/mediawiki-1.{27.3,31.1}: removed vulnerable (bug #637582) (diff)
downloadgentoo-28ab1487a7154b816aa261c3118c148c7fa6f6bf.tar.gz
gentoo-28ab1487a7154b816aa261c3118c148c7fa6f6bf.tar.bz2
gentoo-28ab1487a7154b816aa261c3118c148c7fa6f6bf.zip
"prefix-chain": Remove last-rited pkgs
app-portage/prefix-chain-setup sys-apps/prefix-chain-utils Bug: https://bugs.gentoo.org/658572 Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/prefix-chain-utils/files/prefix-chain-wrapper.in83
-rw-r--r--sys-apps/prefix-chain-utils/files/startprefix.in45
-rw-r--r--sys-apps/prefix-chain-utils/metadata.xml8
-rw-r--r--sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r7.ebuild64
4 files changed, 0 insertions, 200 deletions
diff --git a/sys-apps/prefix-chain-utils/files/prefix-chain-wrapper.in b/sys-apps/prefix-chain-utils/files/prefix-chain-wrapper.in
deleted file mode 100644
index d612cc46bb28..000000000000
--- a/sys-apps/prefix-chain-utils/files/prefix-chain-wrapper.in
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/usr/bin/env bash
-
-if [ -r /cygdrive/. ]; then
- winpath2unix() { cygpath -u "$1"; }
- unixpath2win() { cygpath -w "$1"; }
-fi
-
-link_dirs=()
-opts=()
-chost="@GENTOO_PORTAGE_CHOST@"
-prefix="@GENTOO_PORTAGE_EPREFIX@"
-absprefix=${prefix}
-if [[ ${CHOST} == *"-winnt"* ]]; then
- # we may get called from windows binary, like pkgdata in dev-libs/icu
- # in this case, PATH elements get the "/dev/fs/C/WINDOWS/SUA" prefix
- absprefix=$(winpath2unix "$(unixpath2win "${absprefix}")")
-fi
-[[ $0 == *windres* ]] && mode=compile || mode=link
-orig_args=("$@")
-
-for opt in "$@"; do
- case "$opt" in
- -L) link_dirs=("${link_dirs[@]}" "-L$1"); shift ;;
- -L*) link_dirs=("${link_dirs[@]}" "${opt}") ;;
- *)
- case "${opt}" in
- -v)
- # -v done right: only use mode version if -v is the _only_
- # argument on the command line.
- [[ ${#orig_args[@]} -gt 1 ]] || mode=version
- ;;
- --version) mode=version ;;
- -c|-E|-S) mode=compile ;;
- -print-search-dirs) mode=dirs ;;
- esac
- opts=("${opts[@]}" "${opt}")
- ;;
- esac
-done
-
-save_ifs=$IFS
-IFS=':'
-new_path=
-for p in $PATH; do
- IFS=$save_ifs
- [[ "${p#${absprefix}}" != "${p}" ]] && continue
- if [[ -z "${new_path}" ]]; then
- new_path="${p}"
- else
- new_path="${new_path}:${p}"
- fi
-done
-IFS=$save_ifs
-
-PATH=${new_path}
-
-# toolchain-prefix-wrapper's ld-wrapper understands '-R' for aix and hpux too.
-# parity (winnt) understands -rpath only ...
-case "${chost}" in
-*-winnt*) rpath_opt="-Wl,-rpath," ;;
-*) rpath_opt="-Wl,-R," ;;
-esac
-
-pfx_link=("-L${prefix}/usr/lib" "-L${prefix}/lib")
-pfx_link_r=("${rpath_opt}${prefix}/lib" "${rpath_opt}${prefix}/usr/lib")
-pfx_comp=("-I${prefix}/include" "-I${prefix}/usr/include")
-
-case "$mode" in
-link) exec "$(basename $0)" "${link_dirs[@]}" "${pfx_link[@]}" "${opts[@]}" "${pfx_comp[@]}" "${pfx_link_r[@]}" ;;
-compile) exec "$(basename $0)" "${link_dirs[@]}" "${opts[@]}" "${pfx_comp[@]}" ;;
-version) exec "$(basename $0)" "${orig_args[@]}" ;;
-dirs)
- "$(basename $0)" "${orig_args[@]}" | while read line; do
- if [[ "${line}" == "libraries: ="* ]]; then
- echo "libraries: =${prefix}/usr/lib:${prefix}/lib:${line#"libraries: ="}"
- else
- echo "${line}"
- fi
- done
- ;;
-*) echo "cannot infer $0's mode from comamnd line arguments"; exit 1 ;;
-esac
-
diff --git a/sys-apps/prefix-chain-utils/files/startprefix.in b/sys-apps/prefix-chain-utils/files/startprefix.in
deleted file mode 100644
index 3882ffe14a9c..000000000000
--- a/sys-apps/prefix-chain-utils/files/startprefix.in
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/usr/bin/env bash
-
-if [[ -r "@GENTOO_PORTAGE_EPREFIX@"/lib/gentoo/functions.sh ]]; then
- . "@GENTOO_PORTAGE_EPREFIX@"/lib/gentoo/functions.sh
-elif [[ -r "@GENTOO_PORTAGE_EPREFIX@"/etc/init.d/functions.sh ]]; then
- . "@GENTOO_PORTAGE_EPREFIX@"/etc/init.d/functions.sh
-elif [[ -r "@GENTOO_PORTAGE_EPREFIX@"/sbin/functions.sh ]]; then
- . "@GENTOO_PORTAGE_EPREFIX@"/sbin/functions.sh
-fi
-
-einfo "entering chained prefix @GENTOO_PORTAGE_EPREFIX@ ..."
-
-# inform profiles very early of us beeing interactive (or at least,
-# we will _start_ an interactive shell, so we want the according bits.)
-set -i
-
-. "@GENTOO_PORTAGE_EPREFIX@"/etc/profile
-
-# if there is no local portage, foreign portage instances need to know
-# where to merge to - and thus we need to set EPREFIX.
-# the other way round, if there is a local portage, EPREFIX may not
-# point anywhere else than to our local EPREFIX or be unset...
-
-# DISABLED: this is done by etc/profile now, to be able to start a
-# prefix environment by sourcing etc/profile.
-
-#if [[ -x "@GENTOO_PORTAGE_EPREFIX@"/usr/bin/emerge ]]; then
-# if [[ -n "${EPREFIX}" ]] && [[ "${EPREFIX}" != "@GENTOO_PORTAGE_EPREFIX@" ]]; then
-# ewarn "EPREFIX is set. this will render portage unusable, unsetting"
-# unset EPREFIX
-# fi
-#else
-# export EPREFIX="@GENTOO_PORTAGE_EPREFIX@"
-#fi
-
-# a common problem: the child has no less installed, but baselayout insists
-# on setting PAGER to EPREFIX/usr/bin/less. everything gets back to normal
-# when unsetting PAGER in this case.
-if [[ ! -x "${PAGER}" ]]; then
- unset PAGER
-fi
-
-bash --noprofile
-einfo "leaving chained prefix @GENTOO_PORTAGE_EPREFIX@ ..."
-
diff --git a/sys-apps/prefix-chain-utils/metadata.xml b/sys-apps/prefix-chain-utils/metadata.xml
deleted file mode 100644
index d33cce94b0d4..000000000000
--- a/sys-apps/prefix-chain-utils/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>prefix@gentoo.org</email>
- <name>Gentoo Prefix</name>
-</maintainer>
-</pkgmetadata>
diff --git a/sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r7.ebuild b/sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r7.ebuild
deleted file mode 100644
index b447752a1536..000000000000
--- a/sys-apps/prefix-chain-utils/prefix-chain-utils-0.2-r7.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit prefix
-
-DESCRIPTION="Chained EPREFIX utilities and wrappers"
-HOMEPAGE="https://dev.gentoo.org/~haubi"
-SRC_URI=""
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~ppc-aix ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
-IUSE=""
-
-DEPEND=""
-RDEPEND="sys-devel/gcc-config"
-
-src_unpack() {
- mkdir -p "${S}"
-}
-
-src_install() {
- cp "${FILESDIR}"/*.in "${T}"
- eprefixify "${T}"/*.in
-
- for x in "${T}"/*.in; do
- mv ${x} ${x%.in}
- done
-
- # install toolchain wrapper.
- wrapperdir=/usr/${CHOST}/gcc-bin/${CHOST}-prefix-chain-wrapper/${PV}
- wrappercfg=${CHOST}-prefix-chain-wrapper-${PV}
-
- exeinto $wrapperdir
- sed -i -e "s,@GENTOO_PORTAGE_CHOST@,${CHOST},g" "${T}"/prefix-chain-wrapper
- doexe "${T}"/prefix-chain-wrapper
-
- dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-gcc
- dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-g++
- dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-cpp
- dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-c++
- dosym $wrapperdir/prefix-chain-wrapper $wrapperdir/${CHOST}-windres
-
- dosym $wrapperdir/${CHOST}-gcc $wrapperdir/gcc
- dosym $wrapperdir/${CHOST}-g++ $wrapperdir/g++
- dosym $wrapperdir/${CHOST}-cpp $wrapperdir/cpp
- dosym $wrapperdir/${CHOST}-c++ $wrapperdir/c++
- dosym $wrapperdir/${CHOST}-windres $wrapperdir/windres
-
- # LDPATH is required to keep gcc-config happy :(
- cat > "${T}"/$wrappercfg <<EOF
-GCC_PATH="${EPREFIX}/$wrapperdir"
-LDPATH="${EPREFIX}/$wrapperdir"
-EOF
-
- insinto /etc/env.d/gcc
- doins "${T}"/$wrappercfg
-
- # install startprefix script.
- exeinto /
- doexe "${T}"/startprefix
-}