summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-11-05 00:39:30 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-11-05 00:39:30 +0100
commitb67739f35ad1f35569215b985db2161a301be400 (patch)
tree078ae0d6264265d400445c9868c5932a01d32170 /sys-apps
parentdev-libs/libmspack: Stabilize 1.11 ppc, #941481 (diff)
downloadgentoo-b67739f35ad1f35569215b985db2161a301be400.tar.gz
gentoo-b67739f35ad1f35569215b985db2161a301be400.tar.bz2
gentoo-b67739f35ad1f35569215b985db2161a301be400.zip
sys-apps/cpuid: fix patch
Closes: https://bugs.gentoo.org/942764 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/cpuid/cpuid-20241023.ebuild2
-rw-r--r--sys-apps/cpuid/files/cpuid-20241023-makefile.patch38
2 files changed, 39 insertions, 1 deletions
diff --git a/sys-apps/cpuid/cpuid-20241023.ebuild b/sys-apps/cpuid/cpuid-20241023.ebuild
index c2868c0d5525..f9116f2c451e 100644
--- a/sys-apps/cpuid/cpuid-20241023.ebuild
+++ b/sys-apps/cpuid/cpuid-20241023.ebuild
@@ -20,7 +20,7 @@ BDEPEND="
DOCS=( "ChangeLog" "FUTURE" )
-PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+PATCHES=( "${FILESDIR}/${PN}-20241023-makefile.patch" )
src_prepare() {
default
diff --git a/sys-apps/cpuid/files/cpuid-20241023-makefile.patch b/sys-apps/cpuid/files/cpuid-20241023-makefile.patch
new file mode 100644
index 000000000000..fa4d4c02e2a9
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20241023-makefile.patch
@@ -0,0 +1,38 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS+=-g
++CFLAGS+=
+ CPPFLAGS?=
+ LDFLAGS?=
+ ifneq (,$(findstring arch=i386,$(CFLAGS)))
+@@ -6,7 +6,7 @@
+ endif
+ CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -W -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wimplicit-fallthrough -Wunused-parameter -Wundef -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
+ CFL_OPT=-O3 $(CFL) -Wformat-overflow=2
+-INSTALL_STRIP=-s
++INSTALL_STRIP=
+
+ PACKAGE=cpuid
+ VERSION=20241023
+@@ -41,7 +41,7 @@
+
+ BUILDROOT=$(DESTDIR)
+
+-default: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
++default: $(PROG) cpuinfo2cpuid
+
+ $(PROG): cpuid.c Makefile
+ $(CC) $(CFL) $(LDFLAGS) -o $@ cpuid.c
+@@ -62,9 +62,9 @@
+
+ install: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
+ install -D $(INSTALL_STRIP) -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
++ install -D -m 444 $(PROG).man $(BUILDROOT)/usr/share/man/man1/$(PROG).1
+ install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid
+- install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
++ install -D -m 444 cpuinfo2cpuid.man $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1
+
+ clean:
+ rm -f $(PROG) $(PROG).i386 $(PROG).x86_64