summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2022-04-24 21:26:23 +0800
committerWANG Xuerui <xen0n@gentoo.org>2022-04-25 00:43:16 +0800
commitcb587e35d0ef9e928d72c23645446bd5025183e3 (patch)
treed6565da043c585d68a22943a43fca1374a70f514 /sys-apps
parentacct-user.eclass: add keyword ~loong (diff)
downloadgentoo-cb587e35d0ef9e928d72c23645446bd5025183e3.tar.gz
gentoo-cb587e35d0ef9e928d72c23645446bd5025183e3.tar.bz2
gentoo-cb587e35d0ef9e928d72c23645446bd5025183e3.zip
sys-apps/portage: add support for recognizing LoongArch ABIs
See: https://github.com/gentoo/gentoo/pull/25183 Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/files/3.0.30-loong-abis.patch133
-rw-r--r--sys-apps/portage/portage-3.0.30-r5.ebuild277
2 files changed, 410 insertions, 0 deletions
diff --git a/sys-apps/portage/files/3.0.30-loong-abis.patch b/sys-apps/portage/files/3.0.30-loong-abis.patch
new file mode 100644
index 000000000000..7558107570cd
--- /dev/null
+++ b/sys-apps/portage/files/3.0.30-loong-abis.patch
@@ -0,0 +1,133 @@
+From f6cdba7689ea423245a232cc13103dd988363845 Mon Sep 17 00:00:00 2001
+From: WANG Xuerui <git@xen0n.name>
+Date: Mon, 9 Aug 2021 15:31:25 +0800
+Subject: [PATCH] multilib_category.py: recognize LoongArch ABIs
+
+Add its ELF machine number constant as well. The Gentoo ARCH is "loong";
+all six ABIs defined in the LoongArch ELF psABI spec [1] are supported.
+The upstream binutils port currently implements an earlier version of the
+spec [2]; the ILP32 ABIs are never fully implemented so far, and the
+value for LP64D is coincidentally the same, so the code here stays
+compatible.
+
+This is preparatory work towards a port to the LoongArch architecture,
+which is the new RISC architecture from Loongson Corporation after
+switching away from MIPS.
+
+[1]: https://github.com/loongson/LoongArch-Documentation/blob/23d53fe146a4/docs/LoongArch-ELF-ABI-EN.adoc
+[2]: https://sourceware.org/git/?p=binutils-gdb.git;a=blob;f=include/elf/loongarch.h;h=b4d801ae9bd5a6c4562ca6b1cbae6e6d45d6c704;hb=HEAD
+
+Signed-off-by: WANG Xuerui <git@xen0n.name>
+Closes: https://github.com/gentoo/portage/pull/740
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ lib/portage/dep/soname/multilib_category.py | 26 +++++++++++++++++++++
+ lib/portage/util/elf/constants.py | 9 +++++++
+ 2 files changed, 35 insertions(+)
+
+diff --git a/lib/portage/dep/soname/multilib_category.py b/lib/portage/dep/soname/multilib_category.py
+index ab855d339..567b1d32e 100644
+--- a/lib/portage/dep/soname/multilib_category.py
++++ b/lib/portage/dep/soname/multilib_category.py
+@@ -11,6 +11,7 @@
+ # arm_{32,64}
+ # hppa_{32,64}
+ # ia_{32,64}
++# loong_{ilp32s,ilp32f,ilp32d,lp64s,lp64f,lp64d}
+ # m68k_{32,64}
+ # mips_{eabi32,eabi64,n32,n64,o32,o64}
+ # ppc_{32,64}
+@@ -37,6 +38,13 @@ from portage.util.elf.constants import (
+ EF_MIPS_ABI2,
+ EF_RISCV_FLOAT_ABI_DOUBLE,
+ EF_RISCV_RVC,
++ EF_LOONGARCH_ABI_LP64_SOFT_FLOAT,
++ EF_LOONGARCH_ABI_LP64_SINGLE_FLOAT,
++ EF_LOONGARCH_ABI_LP64_DOUBLE_FLOAT,
++ EF_LOONGARCH_ABI_ILP32_SOFT_FLOAT,
++ EF_LOONGARCH_ABI_ILP32_SINGLE_FLOAT,
++ EF_LOONGARCH_ABI_ILP32_DOUBLE_FLOAT,
++ EF_LOONGARCH_ABI_MASK,
+ ELFCLASS32,
+ ELFCLASS64,
+ EM_386,
+@@ -46,6 +54,7 @@ from portage.util.elf.constants import (
+ EM_ARM,
+ EM_ALTERA_NIOS2,
+ EM_IA_64,
++ EM_LOONGARCH,
+ EM_MIPS,
+ EM_PARISC,
+ EM_PPC,
+@@ -71,6 +80,7 @@ _machine_prefix_map = {
+ EM_ALTERA_NIOS2: "nios2",
+ EM_ARM: "arm",
+ EM_IA_64: "ia64",
++ EM_LOONGARCH: "loong",
+ EM_MIPS: "mips",
+ EM_PARISC: "hppa",
+ EM_PPC: "ppc",
+@@ -84,6 +94,15 @@ _machine_prefix_map = {
+ EM_X86_64: "x86",
+ }
+
++_loong_abi_map = {
++ EF_LOONGARCH_ABI_LP64_SOFT_FLOAT: "lp64s",
++ EF_LOONGARCH_ABI_LP64_SINGLE_FLOAT: "lp64f",
++ EF_LOONGARCH_ABI_LP64_DOUBLE_FLOAT: "lp64d",
++ EF_LOONGARCH_ABI_ILP32_SOFT_FLOAT: "ilp32s",
++ EF_LOONGARCH_ABI_ILP32_SINGLE_FLOAT: "ilp32f",
++ EF_LOONGARCH_ABI_ILP32_DOUBLE_FLOAT: "ilp32d",
++}
++
+ _mips_abi_map = {
+ E_MIPS_ABI_EABI32: "eabi32",
+ E_MIPS_ABI_EABI64: "eabi64",
+@@ -92,6 +111,12 @@ _mips_abi_map = {
+ }
+
+
++def _compute_suffix_loong(elf_header):
++
++ loong_abi = elf_header.e_flags & EF_LOONGARCH_ABI_MASK
++ return _loong_abi_map.get(loong_abi)
++
++
+ def _compute_suffix_mips(elf_header):
+
+ name = None
+@@ -136,6 +161,7 @@ def _compute_suffix_riscv(elf_header):
+
+
+ _specialized_funcs = {
++ "loong": _compute_suffix_loong,
+ "mips": _compute_suffix_mips,
+ "riscv": _compute_suffix_riscv,
+ }
+diff --git a/lib/portage/util/elf/constants.py b/lib/portage/util/elf/constants.py
+index d86b39483..19b72cfa1 100644
+--- a/lib/portage/util/elf/constants.py
++++ b/lib/portage/util/elf/constants.py
+@@ -36,6 +36,7 @@ EM_X86_64 = 62
+ EM_ALTERA_NIOS2 = 113
+ EM_AARCH64 = 183
+ EM_RISCV = 243
++EM_LOONGARCH = 258
+ EM_ALPHA = 0x9026
+
+ E_ENTRY = 24
+@@ -52,3 +53,11 @@ EF_RISCV_FLOAT_ABI_SOFT = 0x0000
+ EF_RISCV_FLOAT_ABI_SINGLE = 0x0002
+ EF_RISCV_FLOAT_ABI_DOUBLE = 0x0004
+ EF_RISCV_FLOAT_ABI_QUAD = 0x0006
++
++EF_LOONGARCH_ABI_LP64_SOFT_FLOAT = 0b001
++EF_LOONGARCH_ABI_LP64_SINGLE_FLOAT = 0b010
++EF_LOONGARCH_ABI_LP64_DOUBLE_FLOAT = 0b011
++EF_LOONGARCH_ABI_ILP32_SOFT_FLOAT = 0b101
++EF_LOONGARCH_ABI_ILP32_SINGLE_FLOAT = 0b110
++EF_LOONGARCH_ABI_ILP32_DOUBLE_FLOAT = 0b111
++EF_LOONGARCH_ABI_MASK = 0x07
+--
+2.35.1
+
diff --git a/sys-apps/portage/portage-3.0.30-r5.ebuild b/sys-apps/portage/portage-3.0.30-r5.ebuild
new file mode 100644
index 000000000000..e3b118e52957
--- /dev/null
+++ b/sys-apps/portage/portage-3.0.30-r5.ebuild
@@ -0,0 +1,277 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_REQ_USE='bzip2(+),threads(+)'
+TMPFILES_OPTIONAL=1
+
+inherit distutils-r1 linux-info toolchain-funcs tmpfiles prefix
+
+DESCRIPTION="The package management and distribution system for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+SRC_URI="https://gitweb.gentoo.org/proj/portage.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux test xattr"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/xz-utils
+ test? ( dev-vcs/git )"
+DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
+ >=app-arch/tar-1.27
+ dev-lang/python-exec:2
+ >=sys-apps/sed-4.0.5 sys-devel/patch
+ doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
+ apidoc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-epytext[${PYTHON_USEDEP}]
+ )"
+# Require sandbox-2.2 for bug #288863.
+# For whirlpool hash, require python[ssl] (bug #425046).
+# For compgen, require bash[readline] (bug #445576).
+# app-portage/gemato goes without PYTHON_USEDEP since we're calling
+# the executable.
+RDEPEND="
+ acct-user/portage
+ app-arch/zstd
+ >=app-arch/tar-1.27
+ dev-lang/python-exec:2
+ >=sys-apps/findutils-4.4
+ !build? (
+ >=sys-apps/sed-4.0.5
+ >=app-shells/bash-5.0:0[readline]
+ >=app-admin/eselect-1.2
+ rsync-verify? (
+ >=app-portage/gemato-14.5[${PYTHON_USEDEP}]
+ >=sec-keys/openpgp-keys-gentoo-release-20180706
+ >=app-crypt/gnupg-2.2.4-r2[ssl(-)]
+ )
+ )
+ elibc_glibc? ( >=sys-apps/sandbox-2.2 )
+ elibc_musl? ( >=sys-apps/sandbox-2.2 )
+ kernel_linux? ( sys-apps/util-linux )
+ >=app-misc/pax-utils-0.1.17
+ selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
+ xattr? ( kernel_linux? (
+ >=sys-apps/install-xattr-0.3
+ ) )
+ !<app-admin/logrotate-3.8.0
+ !<app-portage/gentoolkit-0.4.6
+ !<app-portage/repoman-2.3.10
+ !~app-portage/repoman-3.0.0"
+PDEPEND="
+ !build? (
+ >=net-misc/rsync-2.6.4
+ >=sys-apps/file-5.41
+ >=sys-apps/coreutils-6.4
+ )"
+# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
+# NOTE: FEATURES=installsources requires debugedit and rsync
+
+pkg_pretend() {
+ local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS ~UTS_NS"
+
+ if use native-extensions && tc-is-cross-compiler; then
+ einfo "Disabling USE=native-extensions for cross-compilation (bug #612158)"
+ fi
+
+ check_extra_config
+}
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/3.0.30-revert-default-enable-soname-dependencies.patch"
+ "${FILESDIR}/3.0.30-revert-run-warn.patch"
+ "${FILESDIR}/3.0.30-qa-checks.patch"
+ "${FILESDIR}/3.0.30-loong-abis.patch"
+ )
+
+ distutils-r1_python_prepare_all
+
+ sed -e "s:^VERSION = \"HEAD\"$:VERSION = \"${PV}\":" -i lib/portage/__init__.py || die
+
+ if use gentoo-dev; then
+ einfo "Disabling --dynamic-deps by default for gentoo-dev..."
+ sed -e 's:\("--dynamic-deps", \)\("y"\):\1"n":' \
+ -i lib/_emerge/create_depgraph_params.py || \
+ die "failed to patch create_depgraph_params.py"
+
+ einfo "Enabling additional FEATURES for gentoo-dev..."
+ echo 'FEATURES="${FEATURES} ipc-sandbox network-sandbox strict-keepdir"' \
+ >> cnf/make.globals || die
+ fi
+
+ if use native-extensions && ! tc-is-cross-compiler; then
+ printf "[build_ext]\nportage_ext_modules=true\n" >> \
+ setup.cfg || die
+ fi
+
+ if ! use ipc ; then
+ einfo "Disabling ipc..."
+ sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
+ -i lib/_emerge/AbstractEbuildProcess.py || \
+ die "failed to patch AbstractEbuildProcess.py"
+ fi
+
+ if use xattr && use kernel_linux ; then
+ einfo "Adding FEATURES=xattr to make.globals ..."
+ echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \
+ || die "failed to append to make.globals"
+ fi
+
+ if use build || ! use rsync-verify; then
+ sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
+ -e '/^sync-webrsync-verify-signature/s|yes|no|' \
+ -i cnf/repos.conf || die "sed failed"
+ fi
+
+ if [[ -n ${EPREFIX} ]] ; then
+ einfo "Setting portage.const.EPREFIX ..."
+ hprefixify -e "s|^(EPREFIX[[:space:]]*=[[:space:]]*\").*|\1${EPREFIX}\"|" \
+ -w "/_BINARY/" lib/portage/const.py
+
+ einfo "Prefixing shebangs ..."
+ > "${T}/shebangs" || die
+ while read -r -d $'\0' ; do
+ local shebang=$(head -n1 "$REPLY")
+ if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
+ echo "${REPLY}" >> "${T}/shebangs" || die
+ fi
+ done < <(find . -type f -executable ! -name etc-update -print0)
+
+ if [[ -s ${T}/shebangs ]]; then
+ xargs sed -i -e "1s:^#!:#!${EPREFIX}:" < "${T}/shebangs" || die "sed failed"
+ fi
+
+ einfo "Adjusting make.globals, repos.conf and etc-update ..."
+ hprefixify cnf/{make.globals,repos.conf} bin/etc-update
+
+ if use prefix-guest ; then
+ sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
+ -e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
+ -e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \
+ -i cnf/repos.conf || die "sed failed"
+ fi
+
+ einfo "Adding FEATURES=force-prefix to make.globals ..."
+ echo -e '\nFEATURES="${FEATURES} force-prefix"' >> cnf/make.globals \
+ || die "failed to append to make.globals"
+ fi
+
+ cd "${S}/cnf" || die
+ if [ -f "make.conf.example.${ARCH}".diff ]; then
+ patch make.conf.example "make.conf.example.${ARCH}".diff || \
+ die "Failed to patch make.conf.example"
+ else
+ eerror ""
+ eerror "Portage does not have an arch-specific configuration for this arch."
+ eerror "Please notify the arch maintainer about this issue. Using generic."
+ eerror ""
+ fi
+}
+
+python_compile_all() {
+ local targets=()
+ use doc && targets+=( docbook )
+ use apidoc && targets+=( apidoc )
+
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ local targets=()
+ use doc && targets+=(
+ install_docbook
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ use apidoc && targets+=(
+ install_apidoc
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+
+ # install docs
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
+
+ dotmpfiles "${FILESDIR}"/portage-ccache.conf
+
+ # Due to distutils/python-exec limitations
+ # these must be installed to /usr/bin.
+ local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld'
+ einfo "Moving admin scripts to the correct directory"
+ dodir /usr/sbin
+ for target in ${sbin_relocations}; do
+ einfo "Moving /usr/bin/${target} to /usr/sbin/${target}"
+ mv "${ED}/usr/bin/${target}" "${ED}/usr/sbin/${target}" || die "sbin scripts move failed!"
+ done
+}
+
+pkg_preinst() {
+ if ! use build; then
+ python_setup
+ local sitedir=$(python_get_sitedir)
+ [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+ env -u DISTDIR \
+ -u PORTAGE_OVERRIDE_EPREFIX \
+ -u PORTAGE_REPOSITORIES \
+ -u PORTDIR \
+ -u PORTDIR_OVERLAY \
+ PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+ "${PYTHON}" -m portage._compat_upgrade.default_locations || die
+
+ env -u BINPKG_COMPRESS -u PORTAGE_REPOSITORIES \
+ PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+ "${PYTHON}" -m portage._compat_upgrade.binpkg_compression || die
+
+ env -u FEATURES -u PORTAGE_REPOSITORIES \
+ PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+ "${PYTHON}" -m portage._compat_upgrade.binpkg_multi_instance || die
+ fi
+
+ # elog dir must exist to avoid logrotate error for bug #415911.
+ # This code runs in preinst in order to bypass the mapping of
+ # portage:portage to root:root which happens after src_install.
+ keepdir /var/log/portage/elog
+ # This is allowed to fail if the user/group are invalid for prefix users.
+ if chown portage:portage "${ED}"/var/log/portage{,/elog} 2>/dev/null ; then
+ chmod g+s,ug+rwx "${ED}"/var/log/portage{,/elog}
+ fi
+
+ if has_version "<${CATEGORY}/${PN}-2.3.77"; then
+ elog "The emerge --autounmask option is now disabled by default, except for"
+ elog "portions of behavior which are controlled by the --autounmask-use and"
+ elog "--autounmask-license options. For backward compatibility, previous"
+ elog "behavior of --autounmask=y and --autounmask=n is entirely preserved."
+ elog "Users can get the old behavior simply by adding --autounmask to the"
+ elog "make.conf EMERGE_DEFAULT_OPTS variable. For the rationale for this"
+ elog "change, see https://bugs.gentoo.org/658648."
+ fi
+}