summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-19 09:00:46 +0000
committerSam James <sam@gentoo.org>2021-11-19 09:06:03 +0000
commite0aba0f8c5d55bb8c9dc71787905cc1fe36e1ef4 (patch)
tree9889a28559ac3bc51ba21ed0339af7c22bbe481d /sys-apps
parentapp-text/qpdf: add 10.4.0 (diff)
downloadgentoo-e0aba0f8c5d55bb8c9dc71787905cc1fe36e1ef4.tar.gz
gentoo-e0aba0f8c5d55bb8c9dc71787905cc1fe36e1ef4.tar.bz2
gentoo-e0aba0f8c5d55bb8c9dc71787905cc1fe36e1ef4.zip
sys-apps/most: backport parallel build patch
Closes: https://bugs.gentoo.org/795117 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/most/files/most-5.1.0-fix-parallel-build.patch21
-rw-r--r--sys-apps/most/most-5.1.0.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/most/files/most-5.1.0-fix-parallel-build.patch b/sys-apps/most/files/most-5.1.0-fix-parallel-build.patch
new file mode 100644
index 000000000000..0b5e5b2da3f6
--- /dev/null
+++ b/sys-apps/most/files/most-5.1.0-fix-parallel-build.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/795117
+
+Grabbed from NixOS (slyfox submitted this upstream):
+
+Upstream commit c9cfad50a ("src/Makefile.in: Avoid a race condition
+when performing a parallel build")
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -54,6 +54,12 @@ COMPILE_CMD = $(CC) -c $(ALL_CFLAGS) -DMOST_SYSTEM_INITFILE='"$(SYS_INITFILE)"'
+ all: $(EXEC)
+ $(EXEC): $(OBJDIR) $(CONFIG_H) slangversion $(OBJDIR)/$(EXEC)
+ @echo $(EXEC) created in $(OBJDIR)
++
++# C source files include autogenrated "config.h". Make sure
++# it's available before the compilation. Pessimistically assume
++# any source file can depend on "config.h".
++$(OBJS) $(OBJDIR)/chkslang.o: $(CONFIG_H)
++
+ $(OBJDIR)/$(EXEC): $(OBJS)
+ cd $(OBJDIR); $(CC) $(OFILES) -o $(EXEC) $(LDFLAGS) $(EXECLIBS)
+ #
diff --git a/sys-apps/most/most-5.1.0.ebuild b/sys-apps/most/most-5.1.0.ebuild
index 18b707ef38fb..b09ff495ab76 100644
--- a/sys-apps/most/most-5.1.0.ebuild
+++ b/sys-apps/most/most-5.1.0.ebuild
@@ -18,6 +18,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-5.0.0a-donot-hardcode-path.patch
+ "${FILESDIR}"/${P}-fix-parallel-build.patch
)
src_prepare() {