summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2016-09-26 13:10:31 +0200
committerHanno <hanno@gentoo.org>2016-09-26 13:10:31 +0200
commitc2e9b60123a17da3fa4d6da997df0722aa50edc1 (patch)
tree0cbb0f759f63674040a3a1a8b94e719dbe8f853c /sys-auth/pam_mount/pam_mount-2.16.ebuild
parentprofiles/arch/amd64-fbsd/clang: Change to newway to use libc++ by default (diff)
downloadgentoo-c2e9b60123a17da3fa4d6da997df0722aa50edc1.tar.gz
gentoo-c2e9b60123a17da3fa4d6da997df0722aa50edc1.tar.bz2
gentoo-c2e9b60123a17da3fa4d6da997df0722aa50edc1.zip
sys-auth/pam_mount: Version bump
Should fix compilation with OpenSSL 1.1 (bug #592584). Package-Manager: portage-2.3.1
Diffstat (limited to 'sys-auth/pam_mount/pam_mount-2.16.ebuild')
-rw-r--r--sys-auth/pam_mount/pam_mount-2.16.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-auth/pam_mount/pam_mount-2.16.ebuild b/sys-auth/pam_mount/pam_mount-2.16.ebuild
new file mode 100644
index 000000000000..67ef6624ad9a
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt ssl selinux"
+
+COMMON_DEPEND=">=sys-libs/pam-0.99
+ >=sys-libs/libhx-3.12.1
+ >=dev-libs/libxml2-2.6
+ crypt? ( >=sys-fs/cryptsetup-1.1.0 )
+ ssl? ( dev-libs/openssl:0= )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/util-linux-2.20"
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" \
+ $(use_with crypt cryptsetup) \
+ $(use_with ssl crypto) \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ use selinux || rm -r "${D}"/etc/selinux
+ dodoc doc/*.txt
+}