summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-21 17:23:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-21 17:45:10 +0100
commitaa5f00e41dde6a854658fa8e13b3a9c6fbe94dea (patch)
treec6455b0cbb7470dfa0863214948ec4cd384fee9c /sys-auth/polkit-qt/polkit-qt-0.114.0-r1.ebuild
parentnet-im/choqok: EAPI-8 bump, several upstream fixes (diff)
downloadgentoo-aa5f00e41dde6a854658fa8e13b3a9c6fbe94dea.tar.gz
gentoo-aa5f00e41dde6a854658fa8e13b3a9c6fbe94dea.tar.bz2
gentoo-aa5f00e41dde6a854658fa8e13b3a9c6fbe94dea.zip
sys-auth/polkit-qt: EAPI-8 bump, two upstream backports
Drop IUSE debug no-op Improve cmake (not perfect yet) Drop glib no-op by depending on >=2.36 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-auth/polkit-qt/polkit-qt-0.114.0-r1.ebuild')
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.114.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-auth/polkit-qt/polkit-qt-0.114.0-r1.ebuild b/sys-auth/polkit-qt/polkit-qt-0.114.0-r1.ebuild
new file mode 100644
index 000000000000..d2ed0e07d44f
--- /dev/null
+++ b/sys-auth/polkit-qt/polkit-qt-0.114.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="libraries"
+KDE_ORG_NAME="polkit-qt-1"
+inherit cmake kde.org
+
+DESCRIPTION="Qt wrapper around polkit-1 client libraries"
+HOMEPAGE="https://api.kde.org/polkit-qt-1/html/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${KDE_ORG_NAME}/${KDE_ORG_NAME}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=sys-auth/polkit-0.103
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS README README.porting TODO )
+
+PATCHES=(
+ "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${P}-glib-2.36.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ )
+ cmake_src_configure
+}