summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-09-15 15:34:15 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-09-15 15:35:40 +0200
commit0cdf7706e3ef19075494a8c33804f81373ff4609 (patch)
tree33b4775a9666ae54aac86f8a2f44d8510982bdf5 /sys-auth
parentsys-block/arcconf: add 4.18.00.26842 (diff)
downloadgentoo-0cdf7706e3ef19075494a8c33804f81373ff4609.tar.gz
gentoo-0cdf7706e3ef19075494a8c33804f81373ff4609.tar.bz2
gentoo-0cdf7706e3ef19075494a8c33804f81373ff4609.zip
sys-auth/AusweisApp: add 2.2.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp/AusweisApp-2.2.1.ebuild47
-rw-r--r--sys-auth/AusweisApp/Manifest1
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp/AusweisApp-2.2.1.ebuild b/sys-auth/AusweisApp/AusweisApp-2.2.1.ebuild
new file mode 100644
index 000000000000..d86746427953
--- /dev/null
+++ b/sys-auth/AusweisApp/AusweisApp-2.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-qt/qtshadertools:6
+ dev-qt/qttools:6[linguist]
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtbase:6[concurrent,network,widgets]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtscxml:6[qml]
+ dev-qt/qtsvg:6
+ dev-qt/qtwebsockets:6[qml]
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp/Manifest b/sys-auth/AusweisApp/Manifest
index 36e20ffc000a..e5bd4efedb19 100644
--- a/sys-auth/AusweisApp/Manifest
+++ b/sys-auth/AusweisApp/Manifest
@@ -1 +1,2 @@
DIST AusweisApp-2.2.0.tar.gz 5923990 BLAKE2B 32128246798d5241bfa9388c1a62664d748b16504c67cd20f1fe5cdf10f0d0489dd5b17f9d128d57ffc431f83b72d31222db98ae4f39abbfd216e01c05c40753 SHA512 32d23896e836fbc2cfe5ab9654bd8f5b6773d8413da1c07fb68989b41aa9ec9cd3b6e44dd0154b525a710644786f5e4c8d324401e3f4aa342938852462caeb18
+DIST AusweisApp-2.2.1.tar.gz 5929111 BLAKE2B b6ad3f09597a31d9be347d0b3dfeadb0d0b5ea48e5c257989b38180a09f7ef5f0e6fdec66942c9ff3d173dece7a84ae122c4180705c909becd552d96c92493c3 SHA512 6d1c5ab27fe2ab8fe17f238d27321562e9546cdbb09999472ae2490bc0c3990d43af20557a1a88fff54faad6bed56e97c90732159a1d52683cce0d42c43b2e83