summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2023-02-27 23:30:06 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2023-02-27 23:30:59 +0100
commite7a06624442ad25bdbb3b58f5192db021cb62900 (patch)
treed7f99d2deca4ef36c6a3447f33ac0d46ce8e89db /sys-auth
parentsys-auth/ssh-import-id: metadata.xml bump with remote-id. (diff)
downloadgentoo-e7a06624442ad25bdbb3b58f5192db021cb62900.tar.gz
gentoo-e7a06624442ad25bdbb3b58f5192db021cb62900.tar.bz2
gentoo-e7a06624442ad25bdbb3b58f5192db021cb62900.zip
sys-auth/ssh-import-id: 5.11-r1: py3.11 support; PEP517.
Closes: https://bugs.gentoo.org/897270 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild b/sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild
new file mode 100644
index 000000000000..5e367ecf4375
--- /dev/null
+++ b/sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to securely retrieve an SSH public key and install it locally"
+HOMEPAGE="https://launchpad.net/ssh-import-id"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ doman usr/share/man/man1/ssh-import-id.1
+}