summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/dellmgr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/dellmgr')
-rw-r--r--sys-block/dellmgr/Manifest1
-rw-r--r--sys-block/dellmgr/dellmgr-5.32-r1.ebuild39
-rwxr-xr-xsys-block/dellmgr/files/dellmgr-r224
-rw-r--r--sys-block/dellmgr/metadata.xml7
4 files changed, 71 insertions, 0 deletions
diff --git a/sys-block/dellmgr/Manifest b/sys-block/dellmgr/Manifest
new file mode 100644
index 000000000000..607c26d35dd1
--- /dev/null
+++ b/sys-block/dellmgr/Manifest
@@ -0,0 +1 @@
+DIST perc-apps-A08.tar.gz 761709 SHA256 9e1700dbe72a4557c449829be6ac4ca94c241f87ac42c015091e36336c1a706a SHA512 0a29b9a29216e81740488718307a85aac9560384ef8ba0d4bebdaf91b48d366cf6c4e025b17656abf03a2b8074f18c4595d88f3929e03233a08863b08f9d2d85 WHIRLPOOL f92e6d7c269585ce62f666d2a7fab7d2819bb005b1f1a5e02793fb570bc8415b7348be6dec53bdfd3a7531681a910db65f4dbf67e3a2f8df6e4f9ceeb25b2a06
diff --git a/sys-block/dellmgr/dellmgr-5.32-r1.ebuild b/sys-block/dellmgr/dellmgr-5.32-r1.ebuild
new file mode 100644
index 000000000000..4e0378b3ff26
--- /dev/null
+++ b/sys-block/dellmgr/dellmgr-5.32-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib rpm
+
+MY_PV=${PV}-0
+DESCRIPTION="Dell PERC 2/3/4 RAID controller management tool"
+HOMEPAGE="http://linux.dell.com/"
+SRC_URI="http://ftp.us.dell.com/scsi-raid/perc-apps-A08.tar.gz"
+
+LICENSE="Dell"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="strip mirror test"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ use amd64 && { has_multilib_profile || die "needs multilib profile on amd64"; }
+}
+
+src_unpack() {
+ unpack ${A}
+ rpm_unpack "${S}"/Dellmgr-${MY_PV}.i386.rpm || die "failed to unpack RPM"
+}
+
+src_compile() {
+ echo "Nothing to compile."
+}
+
+src_install() {
+ newsbin "${FILESDIR}"/dellmgr-r2 dellmgr
+ dosbin usr/sbin/dellmgr.bin
+}
diff --git a/sys-block/dellmgr/files/dellmgr-r2 b/sys-block/dellmgr/files/dellmgr-r2
new file mode 100755
index 000000000000..907a1168e37f
--- /dev/null
+++ b/sys-block/dellmgr/files/dellmgr-r2
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+# Get the major number of the megadev ioctl device node
+megadev_major=$(egrep '[[:space:]]megadev(_legacy)?$' /proc/devices 2>/dev/null | awk '{print $1}' 2>/dev/null)
+megadev_node=/dev/megadev0
+
+# MegaRAID device node major number found
+if [ -z "${megadev_major}" ]; then
+ echo "ERROR: failed to determine device node major number"
+ exit 1
+fi
+if [ -e "${megadev_node}" ]; then
+ if ! rm -f "${megadev_node}"; then
+ echo "ERROR: failed to remove existing device node ${megadev_node}"
+ exit 1
+ fi
+fi
+if ! mknod "${megadev_node}" c "${megadev_major}" 0; then
+ echo "ERROR: failed to create device node ${megadev_node}"
+ exit 1
+fi
+
+# Start the real dellmgr binary
+"${0%/*}/dellmgr.bin" "${@}"
diff --git a/sys-block/dellmgr/metadata.xml b/sys-block/dellmgr/metadata.xml
new file mode 100644
index 000000000000..a40624fba8f0
--- /dev/null
+++ b/sys-block/dellmgr/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>