summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-27 08:03:35 +0100
committerSam James <sam@gentoo.org>2023-07-27 08:03:35 +0100
commit7ac728cba6134ea687a4ff73eb010b6ae42d4f59 (patch)
tree08c5548dd674f40ae931c4ccc6bd5edd1db40042 /sys-block/seekwatcher/seekwatcher-0.14.ebuild
parentapp-admin/setools: add 4.4.2 (diff)
downloadgentoo-7ac728cba6134ea687a4ff73eb010b6ae42d4f59.tar.gz
gentoo-7ac728cba6134ea687a4ff73eb010b6ae42d4f59.tar.bz2
gentoo-7ac728cba6134ea687a4ff73eb010b6ae42d4f59.zip
sys-block/seekwatcher: add 0.14
Closes: https://bugs.gentoo.org/898732 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block/seekwatcher/seekwatcher-0.14.ebuild')
-rw-r--r--sys-block/seekwatcher/seekwatcher-0.14.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-block/seekwatcher/seekwatcher-0.14.ebuild b/sys-block/seekwatcher/seekwatcher-0.14.ebuild
new file mode 100644
index 000000000000..06cc3475743f
--- /dev/null
+++ b/sys-block/seekwatcher/seekwatcher-0.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generates graphs from blktrace to help visualize IO patterns and performance"
+HOMEPAGE="https://github.com/trofi/seekwatcher"
+SRC_URI="https://github.com/trofi/seekwatcher/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ sys-block/blktrace
+"