summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-07-30 15:55:23 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-07-30 15:55:43 -0400
commit4bb0ef3b3d20561d8877fc042584ce716206aa88 (patch)
treeff030a6c356116e9b4f153d92ad167e07b085082 /sys-boot/shim/shim-15.5-r1.ebuild
parentdev-vcs/easygit: 1.7.5.2 version bump (diff)
downloadgentoo-4bb0ef3b3d20561d8877fc042584ce716206aa88.tar.gz
gentoo-4bb0ef3b3d20561d8877fc042584ce716206aa88.tar.bz2
gentoo-4bb0ef3b3d20561d8877fc042584ce716206aa88.zip
sys-boot/shim: 32 bit user != 32 bit system
users may wish to run 32 bit despite system being 64 bit, so just install both Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'sys-boot/shim/shim-15.5-r1.ebuild')
-rw-r--r--sys-boot/shim/shim-15.5-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-boot/shim/shim-15.5-r1.ebuild b/sys-boot/shim/shim-15.5-r1.ebuild
new file mode 100644
index 000000000000..2d1591310850
--- /dev/null
+++ b/sys-boot/shim/shim-15.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rpm
+
+DESCRIPTION="Fedora's signed UEFI shim"
+HOMEPAGE="https://apps.fedoraproject.org/packages/shim/"
+MY_PV="${PV/./-}"
+SRC_URI="amd64? ( https://kojipkgs.fedoraproject.org//packages/shim/15/5/x86_64/shim-x64-${MY_PV}.x86_64.rpm
+ https://kojipkgs.fedoraproject.org//packages/shim/15/5/x86_64/shim-ia32-${MY_PV}.x86_64.rpm )
+ x86? ( https://kojipkgs.fedoraproject.org//packages/shim/15/5/x86_64/shim-x64-${MY_PV}.x86_64.rpm
+ https://kojipkgs.fedoraproject.org//packages/shim/15/5/x86_64/shim-ia32-${MY_PV}.x86_64.rpm )
+ arm64? ( https://kojipkgs.fedoraproject.org//packages/shim/15/5/aarch64/shim-aa64-${MY_PV}.aarch64.rpm )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/boot/efi/EFI"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins BOOT/BOOT*.EFI
+ doins fedora/mm*.efi
+}