summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/cluster-glue/cluster-glue-1.0.10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/cluster-glue/cluster-glue-1.0.10.ebuild')
-rw-r--r--sys-cluster/cluster-glue/cluster-glue-1.0.10.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/sys-cluster/cluster-glue/cluster-glue-1.0.10.ebuild b/sys-cluster/cluster-glue/cluster-glue-1.0.10.ebuild
new file mode 100644
index 000000000000..57becbdc3bcc
--- /dev/null
+++ b/sys-cluster/cluster-glue/cluster-glue-1.0.10.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P="${P/cluster-}"
+inherit autotools multilib eutils base user
+
+DESCRIPTION="Library pack for Heartbeat / Pacemaker"
+HOMEPAGE="http://www.linux-ha.org/wiki/Cluster_Glue"
+SRC_URI="http://hg.linux-ha.org/glue/archive/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+IUSE="doc libnet static-libs"
+
+RDEPEND="app-arch/bzip2
+ dev-libs/glib:2
+ dev-libs/libaio
+ libnet? ( net-libs/libnet:1.1 )
+ net-misc/curl
+ net-misc/iputils
+ || ( net-misc/netkit-telnetd net-misc/telnet-bsd )
+ dev-libs/libxml2
+ !<sys-cluster/heartbeat-3.0"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ )"
+
+S="${WORKDIR}/Reusable-Cluster-Components-glue--${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/1.0.5-docs.patch"
+ "${FILESDIR}/1.0.5-respect_cflags.patch"
+ "${FILESDIR}/1.0.7-fix_configure.patch"
+)
+
+pkg_setup() {
+ enewgroup haclient
+ enewuser hacluster -1 /dev/null /var/lib/heartbeat haclient
+}
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myopts
+
+ use doc && myopts=" --enable-doc"
+ econf \
+ $(use_enable libnet) \
+ $(use_enable static-libs static) \
+ --disable-fatal-warnings \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localstatedir=/var \
+ --with-ocf-root=/usr/$(get_libdir)/ocf \
+ ${myopts} \
+ --with-group-id=$(id -g hacluster) \
+ --with-ccmuser-id=$(id -u hacluster) \
+ --with-daemon-user=hacluster --with-daemon-group=haclient
+}
+
+src_install() {
+ base_src_install
+
+ dodir /var/lib/heartbeat/cores
+ dodir /var/lib/heartbeat/lrm
+
+ keepdir /var/lib/heartbeat/cores
+ keepdir /var/lib/heartbeat/lrm
+
+ # init.d file
+ cp "${FILESDIR}"/heartbeat-logd.init "${T}/" || die
+ sed -i \
+ -e "s:%libdir%:$(get_libdir):" \
+ "${T}/heartbeat-logd.init" || die
+# newinitd "${T}/heartbeat-logd.init" heartbeat-logd || die
+ rm "${D}"/etc/init.d/logd
+
+ use static-libs || find "${D}" -type f -name "*.la" -delete
+}
+
+pkg_postinst() {
+ chown -R hacluster:haclient /var/lib/heartbeat/cores
+ chown -R hacluster:haclient /var/lib/heartbeat/lrm
+}