summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-12-17 16:12:27 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-12-17 16:12:27 +0100
commita2faa0e048704bb6c0f2711c8a3598b7ef585b55 (patch)
tree7ccf3915b23e12f377ded3c1cdcb9c4734d4fb38 /sys-cluster/kube-proxy/kube-proxy-1.15.7.ebuild
parentsys-cluster/kube-proxy: Version bump to 1.16.4 (diff)
downloadgentoo-a2faa0e048704bb6c0f2711c8a3598b7ef585b55.tar.gz
gentoo-a2faa0e048704bb6c0f2711c8a3598b7ef585b55.tar.bz2
gentoo-a2faa0e048704bb6c0f2711c8a3598b7ef585b55.zip
sys-cluster/kube-proxy: Version bump to 1.15.7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'sys-cluster/kube-proxy/kube-proxy-1.15.7.ebuild')
-rw-r--r--sys-cluster/kube-proxy/kube-proxy-1.15.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-cluster/kube-proxy/kube-proxy-1.15.7.ebuild b/sys-cluster/kube-proxy/kube-proxy-1.15.7.ebuild
new file mode 100644
index 000000000000..f519690e8b2f
--- /dev/null
+++ b/sys-cluster/kube-proxy/kube-proxy-1.15.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="k8s.io/kubernetes"
+ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Kubernetes Proxy service"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="dev-go/go-bindata
+ >=dev-lang/go-1.11"
+
+RDEPEND="net-firewall/conntrack-tools"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
+ sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
+}
+
+src_compile() {
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin _output/bin/${PN}
+ popd || die
+ keepdir /var/log/${PN} /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+}