summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2023-04-07 00:39:35 -0400
committerKenton Groombridge <concord@gentoo.org>2023-04-07 00:39:35 -0400
commitccfbcb2084aaf192b603146b0930b9af14ca83b1 (patch)
tree8f4ccf81de5a7e2b1efa20f886a646f9d9768e27 /sys-cluster
parentapp-containers/docker-buildx: 0.10.4-r1 revbump to fix dependencies (diff)
downloadgentoo-ccfbcb2084aaf192b603146b0930b9af14ca83b1.tar.gz
gentoo-ccfbcb2084aaf192b603146b0930b9af14ca83b1.tar.bz2
gentoo-ccfbcb2084aaf192b603146b0930b9af14ca83b1.zip
sys-cluster/flux: add missing die
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/flux/flux-0.41.2.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-cluster/flux/flux-0.41.2.ebuild b/sys-cluster/flux/flux-0.41.2.ebuild
index 0a791c2eca47..3e8f5b0393f5 100644
--- a/sys-cluster/flux/flux-0.41.2.ebuild
+++ b/sys-cluster/flux/flux-0.41.2.ebuild
@@ -21,7 +21,7 @@ RESTRICT+=" test"
S="${WORKDIR}/flux2-${PV}"
src_compile() {
- mv "${WORKDIR}"/manifests cmd/"${PN}"
+ mv "${WORKDIR}"/manifests cmd/"${PN}" || die
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
ego build -ldflags="-s -w -X main.VERSION=${PV}" -o ./bin/${PN} ./cmd/${PN}
}