summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-01-07 16:25:38 +0100
committerMichał Górny <mgorny@gentoo.org>2016-01-07 23:09:41 +0100
commit228b9cfe60081550ad12b8079a0caa1e2f762f8f (patch)
tree4d4f3aeab4a74e4aca7f2ab35eb4069b9919bb93 /sys-devel/clang/files
parentwww-plugins/lightspark: Remove old vers requiring llvm-3.2 (diff)
downloadgentoo-228b9cfe60081550ad12b8079a0caa1e2f762f8f.tar.gz
gentoo-228b9cfe60081550ad12b8079a0caa1e2f762f8f.tar.bz2
gentoo-228b9cfe60081550ad12b8079a0caa1e2f762f8f.zip
sys-devel/clang: Remove ancient 3.2 version
Diffstat (limited to 'sys-devel/clang/files')
-rw-r--r--sys-devel/clang/files/clang-2.7-fixdoc.patch53
-rw-r--r--sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-cxx-paths-v2.patch188
-rw-r--r--sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch20
-rw-r--r--sys-devel/clang/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch29
4 files changed, 0 insertions, 290 deletions
diff --git a/sys-devel/clang/files/clang-2.7-fixdoc.patch b/sys-devel/clang/files/clang-2.7-fixdoc.patch
deleted file mode 100644
index 8058ec46bd8f..000000000000
--- a/sys-devel/clang/files/clang-2.7-fixdoc.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -Naur llvm-2.7.orig//tools/clang/docs/Makefile llvm-2.7/tools/clang/docs/Makefile
---- llvm-2.7.orig//tools/clang/docs/Makefile 2010-04-26 18:38:45.000000000 +0200
-+++ llvm-2.7/tools/clang/docs/Makefile 2010-04-26 18:41:08.000000000 +0200
-@@ -46,13 +46,12 @@
- # 'make generated BUILD_FOR_WEBSITE=1'
- generated:: doxygen
-
--install-html: $(PROJ_OBJ_DIR)/html.tar.gz
-+install-html:
- $(Echo) Installing HTML documentation
- $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html
- $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/img
- $(Verb) $(DataInstall) $(HTML) $(DESTDIR)$(PROJ_docsdir)/html
- # $(Verb) $(DataInstall) $(IMAGES) $(DESTDIR)$(PROJ_docsdir)/html/img
-- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(DESTDIR)$(PROJ_docsdir)
-
- $(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
- $(Echo) Packaging HTML documentation
-@@ -64,12 +63,11 @@
- install-doxygen: doxygen
- $(Echo) Installing doxygen documentation
- $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/doxygen
-- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/doxygen.tar.gz $(DESTDIR)$(PROJ_docsdir)
- $(Verb) cd $(PROJ_OBJ_DIR)/doxygen && \
- $(FIND) . -type f -exec \
- $(DataInstall) {} $(DESTDIR)$(PROJ_docsdir)/html/doxygen \;
-
--doxygen: regendoc $(PROJ_OBJ_DIR)/doxygen.tar.gz
-+doxygen: regendoc
-
- regendoc:
- $(Echo) Building doxygen documentation
-diff -Naur llvm-2.7.orig//tools/clang/docs/tools/Makefile llvm-2.7/tools/clang/docs/tools/Makefile
---- llvm-2.7.orig//tools/clang/docs/tools/Makefile 2010-04-26 18:38:45.000000000 +0200
-+++ llvm-2.7/tools/clang/docs/tools/Makefile 2010-04-26 18:41:29.000000000 +0200
-@@ -24,7 +24,7 @@
- CLANG_VERSION := trunk
-
- # If we are in BUILD_FOR_WEBSITE mode, default to the all target.
--all:: html man ps
-+all:: html man
-
- clean:
- rm -f pod2htm*.*~~ $(HTML) $(MAN) $(PS)
-@@ -58,7 +58,7 @@
- ifdef ONLY_MAN_DOCS
- INSTALL_TARGETS := install-man
- else
--INSTALL_TARGETS := install-html install-man install-ps
-+INSTALL_TARGETS := install-html install-man
- endif
-
- .SUFFIXES:
diff --git a/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-cxx-paths-v2.patch b/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-cxx-paths-v2.patch
deleted file mode 100644
index 1053bf3642bc..000000000000
--- a/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-cxx-paths-v2.patch
+++ /dev/null
@@ -1,188 +0,0 @@
-diff --git a/a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp b/b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
-index 1e282f2..1d6835b 100644
---- a/a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
-+++ b/b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
-@@ -2305,6 +2305,162 @@ void Linux::AddClangCXXStdlibIncludeArgs(const ArgList &DriverArgs,
- }
- }
-
-+void FreeBSD::AddClangSystemIncludeArgs(const ArgList &DriverArgs,
-+ ArgStringList &CC1Args) const {
-+ const Driver &D = getDriver();
-+
-+ if (DriverArgs.hasArg(options::OPT_nostdinc))
-+ return;
-+
-+ if (!DriverArgs.hasArg(options::OPT_nostdlibinc))
-+ addSystemInclude(DriverArgs, CC1Args, D.SysRoot + "/usr/local/include");
-+
-+ if (!DriverArgs.hasArg(options::OPT_nobuiltininc)) {
-+ llvm::sys::Path P(D.ResourceDir);
-+ P.appendComponent("include");
-+ addSystemInclude(DriverArgs, CC1Args, P.str());
-+ }
-+
-+ if (DriverArgs.hasArg(options::OPT_nostdlibinc))
-+ return;
-+
-+ // Check for configure-time C include directories.
-+ StringRef CIncludeDirs(C_INCLUDE_DIRS);
-+ if (CIncludeDirs != "") {
-+ SmallVector<StringRef, 5> dirs;
-+ CIncludeDirs.split(dirs, ":");
-+ for (SmallVectorImpl<StringRef>::iterator I = dirs.begin(), E = dirs.end();
-+ I != E; ++I) {
-+ StringRef Prefix = llvm::sys::path::is_absolute(*I) ? D.SysRoot : "";
-+ addExternCSystemInclude(DriverArgs, CC1Args, Prefix + *I);
-+ }
-+ return;
-+ }
-+
-+ // Lacking those, try to detect the correct set of system includes for the
-+ // target triple.
-+
-+ // Implement generic Debian multiarch support.
-+ const StringRef X86_64MultiarchIncludeDirs[] = {
-+ "/usr/include/x86_64-linux-gnu",
-+
-+ // FIXME: These are older forms of multiarch. It's not clear that they're
-+ // in use in any released version of Debian, so we should consider
-+ // removing them.
-+ "/usr/include/i686-linux-gnu/64",
-+ "/usr/include/i486-linux-gnu/64"
-+ };
-+ const StringRef X86MultiarchIncludeDirs[] = {
-+ "/usr/include/i386-linux-gnu",
-+
-+ // FIXME: These are older forms of multiarch. It's not clear that they're
-+ // in use in any released version of Debian, so we should consider
-+ // removing them.
-+ "/usr/include/x86_64-linux-gnu/32",
-+ "/usr/include/i686-linux-gnu",
-+ "/usr/include/i486-linux-gnu"
-+ };
-+ const StringRef ARMMultiarchIncludeDirs[] = {
-+ "/usr/include/arm-linux-gnueabi"
-+ };
-+ const StringRef MIPSMultiarchIncludeDirs[] = {
-+ "/usr/include/mips-linux-gnu"
-+ };
-+ const StringRef MIPSELMultiarchIncludeDirs[] = {
-+ "/usr/include/mipsel-linux-gnu"
-+ };
-+ const StringRef PPCMultiarchIncludeDirs[] = {
-+ "/usr/include/powerpc-linux-gnu"
-+ };
-+ const StringRef PPC64MultiarchIncludeDirs[] = {
-+ "/usr/include/powerpc64-linux-gnu"
-+ };
-+ ArrayRef<StringRef> MultiarchIncludeDirs;
-+ if (getTriple().getArch() == llvm::Triple::x86_64) {
-+ MultiarchIncludeDirs = X86_64MultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::x86) {
-+ MultiarchIncludeDirs = X86MultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::arm) {
-+ MultiarchIncludeDirs = ARMMultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::mips) {
-+ MultiarchIncludeDirs = MIPSMultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::mipsel) {
-+ MultiarchIncludeDirs = MIPSELMultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::ppc) {
-+ MultiarchIncludeDirs = PPCMultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::ppc64) {
-+ MultiarchIncludeDirs = PPC64MultiarchIncludeDirs;
-+ }
-+ for (ArrayRef<StringRef>::iterator I = MultiarchIncludeDirs.begin(),
-+ E = MultiarchIncludeDirs.end();
-+ I != E; ++I) {
-+ if (llvm::sys::fs::exists(D.SysRoot + *I)) {
-+ addExternCSystemInclude(DriverArgs, CC1Args, D.SysRoot + *I);
-+ break;
-+ }
-+ }
-+
-+ if (getTriple().getOS() == llvm::Triple::RTEMS)
-+ return;
-+
-+ // Add an include of '/include' directly. This isn't provided by default by
-+ // system GCCs, but is often used with cross-compiling GCCs, and harmless to
-+ // add even when Clang is acting as-if it were a system compiler.
-+ addExternCSystemInclude(DriverArgs, CC1Args, D.SysRoot + "/include");
-+
-+ addExternCSystemInclude(DriverArgs, CC1Args, D.SysRoot + "/usr/include");
-+}
-+
-+/// \brief Helper to add the thre variant paths for a libstdc++ installation.
-+/*static*/ bool FreeBSD::addLibStdCXXIncludePaths(Twine Base, Twine TargetArchDir,
-+ const ArgList &DriverArgs,
-+ ArgStringList &CC1Args) {
-+ if (!llvm::sys::fs::exists(Base))
-+ return false;
-+ addSystemInclude(DriverArgs, CC1Args, Base);
-+ addSystemInclude(DriverArgs, CC1Args, Base + "/" + TargetArchDir);
-+ addSystemInclude(DriverArgs, CC1Args, Base + "/backward");
-+ return true;
-+}
-+
-+void FreeBSD::AddClangCXXStdlibIncludeArgs(const ArgList &DriverArgs,
-+ ArgStringList &CC1Args) const {
-+ if (DriverArgs.hasArg(options::OPT_nostdlibinc) ||
-+ DriverArgs.hasArg(options::OPT_nostdincxx))
-+ return;
-+
-+ // Check if libc++ has been enabled and provide its include paths if so.
-+ if (GetCXXStdlibType(DriverArgs) == ToolChain::CST_Libcxx) {
-+ // libc++ is always installed at a fixed path on Linux currently.
-+ addSystemInclude(DriverArgs, CC1Args,
-+ getDriver().SysRoot + "/usr/include/c++/v1");
-+ return;
-+ }
-+
-+ // We need a detected GCC installation on Linux to provide libstdc++'s
-+ // headers. We handled the libc++ case above.
-+ if (!GCCInstallation.isValid())
-+ return;
-+
-+ // By default, look for the C++ headers in an include directory adjacent to
-+ // the lib directory of the GCC installation. Note that this is expect to be
-+ // equivalent to '/usr/include/c++/X.Y' in almost all cases.
-+ StringRef LibDir = GCCInstallation.getParentLibPath();
-+ StringRef InstallDir = GCCInstallation.getInstallPath();
-+ StringRef Version = GCCInstallation.getVersion();
-+ if (!addLibStdCXXIncludePaths(LibDir + "/../include/c++/" + Version,
-+ (GCCInstallation.getTriple().str() +
-+ GCCInstallation.getMultiarchSuffix()),
-+ DriverArgs, CC1Args)) {
-+ // Gentoo is weird and places its headers inside the GCC install, so if the
-+ // first attempt to find the headers fails, try this pattern.
-+ addLibStdCXXIncludePaths(InstallDir + "/include/g++-v4",
-+ (GCCInstallation.getTriple().str() +
-+ GCCInstallation.getMultiarchSuffix()),
-+ DriverArgs, CC1Args);
-+ }
-+}
-+
- /// DragonFly - DragonFly tool chain which can call as(1) and ld(1) directly.
-
- DragonFly::DragonFly(const Driver &D, const llvm::Triple& Triple, const ArgList &Args)
-diff --git a/a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.h b/b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.h
-index eaa6be1..bba891e 100644
---- a/a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.h
-+++ b/b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.h
-@@ -489,6 +489,16 @@ public:
-
- virtual Tool &SelectTool(const Compilation &C, const JobAction &JA,
- const ActionList &Inputs) const;
-+
-+ virtual void AddClangSystemIncludeArgs(const ArgList &DriverArgs,
-+ ArgStringList &CC1Args) const;
-+ virtual void AddClangCXXStdlibIncludeArgs(const ArgList &DriverArgs,
-+ ArgStringList &CC1Args) const;
-+
-+private:
-+ static bool addLibStdCXXIncludePaths(Twine Base, Twine TargetArchDir,
-+ const ArgList &DriverArgs,
-+ ArgStringList &CC1Args);
- };
-
- class LLVM_LIBRARY_VISIBILITY NetBSD : public Generic_ELF {
diff --git a/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch b/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch
deleted file mode 100644
index 702606f8a0ca..000000000000
--- a/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-This patch causes problem for multilib: GCCInstallation.getInstallPath() is
-empty in that case and 'clang -m32 foo.c' will put a -L with nothing after it
-but the .o file generated, effectively dropping it.
-With recent freebsd-lib versions, it is only needed for c++ with libstdc++,
-which is actually broken because clang++ cannot find the headers. it is fine
-with clang++ -stdlib=libc++.
-aballier@g.o
-
-diff -upNr a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
---- a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp 2012-05-24 04:08:48.393073000 -0400
-+++ b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp 2012-05-24 04:11:38.113153421 -0400
-@@ -1635,6 +1635,8 @@ FreeBSD::FreeBSD(const Driver &D, const
- getFilePaths().push_back(getDriver().SysRoot + "/usr/lib32");
- else
- getFilePaths().push_back(getDriver().SysRoot + "/usr/lib");
-+
-+ getFilePaths().push_back(GCCInstallation.getInstallPath());
- }
-
- Tool &FreeBSD::SelectTool(const Compilation &C, const JobAction &JA,
diff --git a/sys-devel/clang/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch b/sys-devel/clang/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
deleted file mode 100644
index 49f108533404..000000000000
--- a/sys-devel/clang/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -upNr a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
---- a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp 2012-05-24 03:32:31.593191000 -0400
-+++ b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp 2012-05-24 03:38:31.733163513 -0400
-@@ -1145,6 +1145,25 @@ Generic_GCC::GCCInstallationDetector::GC
- Prefixes.push_back(D.InstalledDir + "/..");
- }
-
-+ llvm::OwningPtr<llvm::MemoryBuffer> File;
-+ for (unsigned k = 0, ke = CandidateTripleAliases.size(); k < ke; ++k) {
-+ if (!llvm::MemoryBuffer::getFile(D.SysRoot + "/etc/env.d/gcc/config-" + CandidateTripleAliases[k].str(), File))
-+ {
-+ bool Exists;
-+ const std::string VersionText = File.get()->getBuffer().rsplit('-').second.substr(0,5).str();
-+ const std::string GentooPath = D.SysRoot + "/usr/lib/gcc/" + CandidateTripleAliases[k].str() + "/" + VersionText;
-+ if (!llvm::sys::fs::exists(GentooPath + "/crtbegin.o", Exists) && Exists)
-+ {
-+ Version = GCCVersion::Parse(VersionText);
-+ GCCInstallPath = GentooPath;
-+ GCCParentLibPath = GCCInstallPath + "/../../..";
-+ GCCTriple.setTriple(CandidateTripleAliases[k]);
-+ IsValid = true;
-+ return;
-+ }
-+ }
-+ }
-+
- // Loop over the various components which exist and select the best GCC
- // installation available. GCC installs are ranked by version number.
- Version = GCCVersion::Parse("0.0.0");