summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-03-04 11:30:45 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-04 11:53:00 +0000
commitf55126b37cbcc9f747584d039d6e356939b3371e (patch)
tree9f6391a422b7a72f32841ba43cfade4b36a51b85 /sys-devel/gcc/gcc-8.4.0.ebuild
parentsys-block/open-iscsi: Removed old (diff)
downloadgentoo-f55126b37cbcc9f747584d039d6e356939b3371e.tar.gz
gentoo-f55126b37cbcc9f747584d039d6e356939b3371e.tar.bz2
gentoo-f55126b37cbcc9f747584d039d6e356939b3371e.zip
sys-devel/gcc: bump up to 8.4.0, patchset 1
patchset 1, is a copy of 8.3.0 patchset without upstreamed patches. The only change from 8.3.0 is removal of 3 upstreamed patches: - 16_all_sh_textrel-on-libitm.patch - 27_all_flto-make-all.patch - 28_all_i386_retpoline-and-jumptable.patch Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-8.4.0.ebuild')
-rw-r--r--sys-devel/gcc/gcc-8.4.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-8.4.0.ebuild b/sys-devel/gcc/gcc-8.4.0.ebuild
new file mode 100644
index 000000000000..ecdde41c0bcb
--- /dev/null
+++ b/sys-devel/gcc/gcc-8.4.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_VER="1"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi