summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-01-25 16:27:14 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-01-25 16:27:23 +0100
commitef49044e3259463b2eb25bc8e125507b0b6f583f (patch)
treefdd0280bf61e75010a8cce0ebf04410b93515d57 /sys-devel/llvm/llvm-9999.ebuild
parentsys-fs/cachefilesd: Correct LICENSE (diff)
downloadgentoo-ef49044e3259463b2eb25bc8e125507b0b6f583f.tar.gz
gentoo-ef49044e3259463b2eb25bc8e125507b0b6f583f.tar.bz2
gentoo-ef49044e3259463b2eb25bc8e125507b0b6f583f.zip
sys-devel/llvm: fix live ebuild
Update clang version, bug #572396 Update llvm-config patch, bug #572564 Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 16c4d32ceacb..d9adc68fc25f 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -160,7 +160,7 @@ src_prepare() {
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358
- epatch "${FILESDIR}"/llvm-3.8-llvm-config.patch
+ epatch "${FILESDIR}"/llvm-3.9-llvm-config.patch
# disable use of SDK on OSX, bug #568758
sed -i -e 's/xcrun/false/' utils/lit/lit/util.py || die
@@ -374,7 +374,7 @@ src_install() {
if use clang; then
# note: magic applied in multilib_src_install()!
- CLANG_VERSION=3.8
+ CLANG_VERSION=3.9
MULTILIB_CHOST_TOOLS+=(
/usr/bin/clang