summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-17 10:56:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-17 11:05:15 +0200
commit59f50ab534d05d11066a072e5355791674928365 (patch)
tree664598c39d63b49e181dd6b768cbd65a4fc90fe7 /sys-devel
parentsys-libs/libomp: Bump to 12.0.1rc2 (diff)
downloadgentoo-59f50ab534d05d11066a072e5355791674928365.tar.gz
gentoo-59f50ab534d05d11066a072e5355791674928365.tar.bz2
gentoo-59f50ab534d05d11066a072e5355791674928365.zip
sys-devel/clang-runtime: Bump to 12.0.1rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-12.0.1_rc2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-12.0.1_rc2.ebuild b/sys-devel/clang-runtime/clang-runtime-12.0.1_rc2.ebuild
new file mode 100644
index 000000000000..218cdb1426f6
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-12.0.1_rc2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"