summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-11 09:27:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-11 09:27:14 +0200
commit6fc20622e792ab8e87fa84736fb215dc40a181e1 (patch)
treeea6f18856972df31aac81b6a3131a2d628b2d5fb /sys-devel
parentdev-python/tree-sitter: Remove old (diff)
downloadgentoo-6fc20622e792ab8e87fa84736fb215dc40a181e1.tar.gz
gentoo-6fc20622e792ab8e87fa84736fb215dc40a181e1.tar.bz2
gentoo-6fc20622e792ab8e87fa84736fb215dc40a181e1.zip
sys-devel/clang-common: Adjust for gcc-config being IDEPEND
Thanks to Arfrever for noticing. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.2-r1.ebuild7
-rw-r--r--sys-devel/clang-common/clang-common-15.0.3.9999.ebuild7
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0.9999.ebuild7
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0_pre20221006-r1.ebuild7
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0_pre20221010-r1.ebuild7
5 files changed, 30 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild b/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild
index c921dc1cf0c6..515cb176e7bd 100644
--- a/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild
@@ -26,6 +26,10 @@ PDEPEND="
default-libcxx? ( >=sys-libs/libcxx-${PV} )
default-lld? ( sys-devel/lld )
"
+IDEPEND="
+ !default-compiler-rt? ( sys-devel/gcc-config )
+ !default-libcxx? ( sys-devel/gcc-config )
+"
LLVM_COMPONENTS=( clang/utils )
llvm.org_set_globals
@@ -115,7 +119,8 @@ src_install() {
}
pkg_preinst() {
- if has_version sys-devel/gcc-config; then
+ if has_version -b sys-devel/gcc-config && has_version sys-devel/gcc
+ then
local gcc_path=$(gcc-config --get-lib-path 2>/dev/null)
if [[ -n ${gcc_path} ]]; then
cat >> "${ED}/etc/clang/gentoo-gcc-install.cfg" <<-EOF
diff --git a/sys-devel/clang-common/clang-common-15.0.3.9999.ebuild b/sys-devel/clang-common/clang-common-15.0.3.9999.ebuild
index 9d8ad198445d..841ceedb1077 100644
--- a/sys-devel/clang-common/clang-common-15.0.3.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.3.9999.ebuild
@@ -29,6 +29,10 @@ PDEPEND="
default-lld? ( sys-devel/lld )
!default-lld? ( sys-devel/binutils )
"
+IDEPEND="
+ !default-compiler-rt? ( sys-devel/gcc-config )
+ !default-libcxx? ( sys-devel/gcc-config )
+"
LLVM_COMPONENTS=( clang/utils )
llvm.org_set_globals
@@ -114,7 +118,8 @@ src_install() {
}
pkg_preinst() {
- if has_version sys-devel/gcc-config; then
+ if has_version -b sys-devel/gcc-config && has_version sys-devel/gcc
+ then
local gcc_path=$(gcc-config --get-lib-path 2>/dev/null)
if [[ -n ${gcc_path} ]]; then
cat >> "${ED}/etc/clang/gentoo-gcc-install.cfg" <<-EOF
diff --git a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
index 9d8ad198445d..841ceedb1077 100644
--- a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
@@ -29,6 +29,10 @@ PDEPEND="
default-lld? ( sys-devel/lld )
!default-lld? ( sys-devel/binutils )
"
+IDEPEND="
+ !default-compiler-rt? ( sys-devel/gcc-config )
+ !default-libcxx? ( sys-devel/gcc-config )
+"
LLVM_COMPONENTS=( clang/utils )
llvm.org_set_globals
@@ -114,7 +118,8 @@ src_install() {
}
pkg_preinst() {
- if has_version sys-devel/gcc-config; then
+ if has_version -b sys-devel/gcc-config && has_version sys-devel/gcc
+ then
local gcc_path=$(gcc-config --get-lib-path 2>/dev/null)
if [[ -n ${gcc_path} ]]; then
cat >> "${ED}/etc/clang/gentoo-gcc-install.cfg" <<-EOF
diff --git a/sys-devel/clang-common/clang-common-16.0.0_pre20221006-r1.ebuild b/sys-devel/clang-common/clang-common-16.0.0_pre20221006-r1.ebuild
index 9d8ad198445d..841ceedb1077 100644
--- a/sys-devel/clang-common/clang-common-16.0.0_pre20221006-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0_pre20221006-r1.ebuild
@@ -29,6 +29,10 @@ PDEPEND="
default-lld? ( sys-devel/lld )
!default-lld? ( sys-devel/binutils )
"
+IDEPEND="
+ !default-compiler-rt? ( sys-devel/gcc-config )
+ !default-libcxx? ( sys-devel/gcc-config )
+"
LLVM_COMPONENTS=( clang/utils )
llvm.org_set_globals
@@ -114,7 +118,8 @@ src_install() {
}
pkg_preinst() {
- if has_version sys-devel/gcc-config; then
+ if has_version -b sys-devel/gcc-config && has_version sys-devel/gcc
+ then
local gcc_path=$(gcc-config --get-lib-path 2>/dev/null)
if [[ -n ${gcc_path} ]]; then
cat >> "${ED}/etc/clang/gentoo-gcc-install.cfg" <<-EOF
diff --git a/sys-devel/clang-common/clang-common-16.0.0_pre20221010-r1.ebuild b/sys-devel/clang-common/clang-common-16.0.0_pre20221010-r1.ebuild
index 9d8ad198445d..841ceedb1077 100644
--- a/sys-devel/clang-common/clang-common-16.0.0_pre20221010-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0_pre20221010-r1.ebuild
@@ -29,6 +29,10 @@ PDEPEND="
default-lld? ( sys-devel/lld )
!default-lld? ( sys-devel/binutils )
"
+IDEPEND="
+ !default-compiler-rt? ( sys-devel/gcc-config )
+ !default-libcxx? ( sys-devel/gcc-config )
+"
LLVM_COMPONENTS=( clang/utils )
llvm.org_set_globals
@@ -114,7 +118,8 @@ src_install() {
}
pkg_preinst() {
- if has_version sys-devel/gcc-config; then
+ if has_version -b sys-devel/gcc-config && has_version sys-devel/gcc
+ then
local gcc_path=$(gcc-config --get-lib-path 2>/dev/null)
if [[ -n ${gcc_path} ]]; then
cat >> "${ED}/etc/clang/gentoo-gcc-install.cfg" <<-EOF