summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-03-14 22:49:20 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-03-14 22:49:37 +0000
commit890e99a6aef35c3e8c9a828bdf5ca9eafec6a1bb (patch)
tree3073ee9d854e031ba4792df2a13d2974934b6c63 /sys-devel
parentdev-python/django-taggit: reusable Django application for simple tagging (diff)
downloadgentoo-890e99a6aef35c3e8c9a828bdf5ca9eafec6a1bb.tar.gz
gentoo-890e99a6aef35c3e8c9a828bdf5ca9eafec6a1bb.tar.bz2
gentoo-890e99a6aef35c3e8c9a828bdf5ca9eafec6a1bb.zip
sys-devel/gdb: fix build against -std=c++17
Patch is proposed upstream as: https://sourceware.org/ml/gdb-patches/2019-03/msg00306.html Reported-by: Helmut Jarausch Closes: https://bugs.gentoo.org/680232 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/files/gdb-8.3.50.20190312-c++17.patch19
-rw-r--r--sys-devel/gdb/gdb-8.3.50.20190312-r1.ebuild1
2 files changed, 20 insertions, 0 deletions
diff --git a/sys-devel/gdb/files/gdb-8.3.50.20190312-c++17.patch b/sys-devel/gdb/files/gdb-8.3.50.20190312-c++17.patch
new file mode 100644
index 000000000000..c134cbcae8df
--- /dev/null
+++ b/sys-devel/gdb/files/gdb-8.3.50.20190312-c++17.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/680232
+
+--- a/gdb/unittests/string_view-selftests.c
++++ b/gdb/unittests/string_view-selftests.c
+@@ -170,10 +170,12 @@ run_tests ()
+ } /* namespace string_view */
+ } /* namespace selftests */
+
++#endif /* __cplusplus < 201703L */
++
+ void
+ _initialize_string_view_selftests ()
+ {
++#if defined(GDB_STRING_VIEW)
+ selftests::register_test ("string_view", selftests::string_view::run_tests);
++#endif
+ }
+-
+-#endif /* __cplusplus < 201703L */
diff --git a/sys-devel/gdb/gdb-8.3.50.20190312-r1.ebuild b/sys-devel/gdb/gdb-8.3.50.20190312-r1.ebuild
index eda29eb876ab..3b02bda0bd96 100644
--- a/sys-devel/gdb/gdb-8.3.50.20190312-r1.ebuild
+++ b/sys-devel/gdb/gdb-8.3.50.20190312-r1.ebuild
@@ -95,6 +95,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-source-highlight.patch
+ "${FILESDIR}"/${P}-c++17.patch
)
S=${WORKDIR}/${PN}-${MY_PV}