summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOldManSeph <sschaefering@gmail.com>2024-12-14 09:47:09 +0000
committerSam James <sam@gentoo.org>2024-12-15 16:15:36 +0000
commitd4e3ec6536fab815dcc9a3b64696ac246d04ef66 (patch)
tree27a32cbd311ac06397d5e7cc3420ade34e567904 /sys-fs/mtpfs
parentdev-libs/intel-compute-runtime: enable support for legacy devices (diff)
downloadgentoo-d4e3ec6536fab815dcc9a3b64696ac246d04ef66.tar.gz
gentoo-d4e3ec6536fab815dcc9a3b64696ac246d04ef66.tar.bz2
gentoo-d4e3ec6536fab815dcc9a3b64696ac246d04ef66.zip
sys-fs/mtpfs: fix for c23 in 1.1-r6
Patch from: https://github.com/cjd/mtpfs/commit/3b7b0d3ac7e15c9b654e19489bb4be84d48698f7.patch Closes: https://bugs.gentoo.org/945802 Signed-off-by: OldManSeph <sschaefering@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39719 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/mtpfs')
-rw-r--r--sys-fs/mtpfs/files/mtpfs-1.1-c23-fix.patch38
-rw-r--r--sys-fs/mtpfs/mtpfs-1.1-r6.ebuild5
2 files changed, 41 insertions, 2 deletions
diff --git a/sys-fs/mtpfs/files/mtpfs-1.1-c23-fix.patch b/sys-fs/mtpfs/files/mtpfs-1.1-c23-fix.patch
new file mode 100644
index 000000000000..a7875276b9a5
--- /dev/null
+++ b/sys-fs/mtpfs/files/mtpfs-1.1-c23-fix.patch
@@ -0,0 +1,38 @@
+From: https://github.com/cjd/mtpfs/commit/3b7b0d3ac7e15c9b654e19489bb4be84d48698f7.patch
+From: Rudi Heitbaum <rudi@heitbaum.com>
+Date: Mon, 9 Dec 2024 12:49:20 +0000
+Subject: [PATCH] fix gcc-15 build
+
+--- a/mtpfs.c
++++ b/mtpfs.c
+@@ -812,7 +812,7 @@ mtpfs_release (const char *path, struct fuse_file_info *fi)
+ }
+
+ void
+-mtpfs_destroy ()
++mtpfs_destroy (void *buf)
+ {
+ enter_lock ("destroy");
+ if (files)
+@@ -1622,7 +1622,7 @@ mtpfs_init ()
+ }
+
+ int
+-mtpfs_blank()
++mtpfs_blank (const char *path, mode_t mode)
+ {
+ // Do nothing
+ }
+
+--- a/mtpfs.h
++++ b/mtpfs.h
+@@ -49,9 +49,9 @@ static int find_storage(const gchar * path);
+
+ /* fuse functions */
+ static void * mtpfs_init (void);
+-static int mtpfs_blank ();
++static int mtpfs_blank (const char *path, mode_t mode);
+ static int mtpfs_release (const char *path, struct fuse_file_info *fi);
+-void mtpfs_destroy ();
++void mtpfs_destroy (void *buf);
+ static int mtpfs_readdir (const gchar * path, void *buf, fuse_fill_dir_t filler, off_t offset, struct fuse_file_info *fi);
diff --git a/sys-fs/mtpfs/mtpfs-1.1-r6.ebuild b/sys-fs/mtpfs/mtpfs-1.1-r6.ebuild
index 04dd5b86b903..e52803d332e5 100644
--- a/sys-fs/mtpfs/mtpfs-1.1-r6.ebuild
+++ b/sys-fs/mtpfs/mtpfs-1.1-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,7 +28,8 @@ PATCHES=( "${FILESDIR}"/${P}-fix-mutex-crash.patch
"${FILESDIR}"/${P}-unitialized-variable.patch
"${FILESDIR}"/${P}-wking-patches/
"${FILESDIR}"/${P}-g_printf.patch
- "${FILESDIR}"/${P}-deprecated_lock_init.patch )
+ "${FILESDIR}"/${P}-deprecated_lock_init.patch
+ "${FILESDIR}"/${P}-c23-fix.patch )
src_prepare() {
default