summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-07 14:28:58 +0100
committerSam James <sam@gentoo.org>2024-05-07 14:32:41 +0100
commit2f8515da6f9a003a209b3de4e76c0cd837c76631 (patch)
tree5e7f9ee21d73b1f8c09ed0dee73b08ccfdc7d98f /sys-fs/xfsprogs
parentsci-libs/vtk: revert "sci-libs/vtk: drop 9.2.5, 9.2.6-r1" (diff)
downloadgentoo-2f8515da6f9a003a209b3de4e76c0cd837c76631.tar.gz
gentoo-2f8515da6f9a003a209b3de4e76c0cd837c76631.tar.bz2
gentoo-2f8515da6f9a003a209b3de4e76c0cd837c76631.zip
sys-fs/xfsprogs: drop useless LTO configure arg
As Eli points out on the bug, it only adds -flto -ffat-lto-objects. It also breaks with Clang unnecessarily. Closes: https://bugs.gentoo.org/930947 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/xfsprogs')
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.4.0.ebuild10
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild10
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.7.0.ebuild10
3 files changed, 9 insertions, 21 deletions
diff --git a/sys-fs/xfsprogs/xfsprogs-6.4.0.ebuild b/sys-fs/xfsprogs/xfsprogs-6.4.0.ebuild
index 6ecca8c43ca8..a82129f2ccf9 100644
--- a/sys-fs/xfsprogs/xfsprogs-6.4.0.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-6.4.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic systemd usr-ldscript toolchain-funcs
+inherit flag-o-matic systemd usr-ldscript
DESCRIPTION="XFS filesystem utilities"
HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git/"
@@ -72,6 +72,8 @@ src_configure() {
local myconf=(
--enable-static
--enable-blkid
+ # Doesn't do anything beyond adding -flto (bug #930947).
+ --disable-lto
--with-crond-dir="${EPREFIX}/etc/cron.d"
--with-systemd-unit-dir="$(systemd_get_systemunitdir)"
$(use_enable icu libicu)
@@ -79,12 +81,6 @@ src_configure() {
$(use_enable libedit editline)
)
- if tc-is-lto ; then
- myconf+=( --enable-lto )
- else
- myconf+=( --disable-lto )
- fi
-
econf "${myconf[@]}"
}
diff --git a/sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild b/sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild
index eb7d1494151c..c46c41e10726 100644
--- a/sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic systemd udev usr-ldscript toolchain-funcs
+inherit flag-o-matic systemd udev usr-ldscript
DESCRIPTION="XFS filesystem utilities"
HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git/"
@@ -74,6 +74,8 @@ src_configure() {
local myconf=(
--enable-static
--enable-blkid
+ # Doesn't do anything beyond adding -flto (bug #930947).
+ --disable-lto
--with-crond-dir="${EPREFIX}/etc/cron.d"
--with-systemd-unit-dir="$(systemd_get_systemunitdir)"
--with-udev-rule-dir="$(get_udevdir)"
@@ -82,12 +84,6 @@ src_configure() {
$(use_enable libedit editline)
)
- if tc-is-lto ; then
- myconf+=( --enable-lto )
- else
- myconf+=( --disable-lto )
- fi
-
econf "${myconf[@]}"
}
diff --git a/sys-fs/xfsprogs/xfsprogs-6.7.0.ebuild b/sys-fs/xfsprogs/xfsprogs-6.7.0.ebuild
index c412012a15f3..13c8f04b9c6e 100644
--- a/sys-fs/xfsprogs/xfsprogs-6.7.0.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-6.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic systemd udev usr-ldscript toolchain-funcs
+inherit flag-o-matic systemd udev usr-ldscript
DESCRIPTION="XFS filesystem utilities"
HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git/"
@@ -71,6 +71,8 @@ src_configure() {
# https://www.spinics.net/lists/linux-xfs/msg30272.html
local myconf=(
--enable-static
+ # Doesn't do anything beyond adding -flto (bug #930947).
+ --disable-lto
--with-crond-dir="${EPREFIX}/etc/cron.d"
--with-systemd-unit-dir="$(systemd_get_systemunitdir)"
--with-udev-rule-dir="$(get_udevdir)"
@@ -79,12 +81,6 @@ src_configure() {
$(use_enable libedit editline)
)
- if tc-is-lto ; then
- myconf+=( --enable-lto )
- else
- myconf+=( --disable-lto )
- fi
-
econf "${myconf[@]}"
}