summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2024-02-24 13:13:08 +0100
committerJakov Smolić <jsmolic@gentoo.org>2024-02-24 13:39:58 +0100
commit001732a54c9f165a6f00d071b5ab53b87c3b1a8e (patch)
tree5c760fd72b7996ac70373891454283b0ee6606a0 /sys-fs
parentsys-kernel/dracut-crypt-ssh: add 1.0.8 (diff)
downloadgentoo-001732a54c9f165a6f00d071b5ab53b87c3b1a8e.tar.gz
gentoo-001732a54c9f165a6f00d071b5ab53b87c3b1a8e.tar.bz2
gentoo-001732a54c9f165a6f00d071b5ab53b87c3b1a8e.zip
sys-fs/genimage: add 17
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/genimage/Manifest1
-rw-r--r--sys-fs/genimage/genimage-17.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/genimage/Manifest b/sys-fs/genimage/Manifest
index d1e942abc896..b8c04dd31f16 100644
--- a/sys-fs/genimage/Manifest
+++ b/sys-fs/genimage/Manifest
@@ -1 +1,2 @@
DIST genimage-16.tar.gz 87544 BLAKE2B 822c1b5901ed3fa19e33961e6e9e718f961d6c0a2315dcb4301aea3cccad6368a03d48ab5b5713592bdd096e78e7d24c03e8016a1470c7864ace71e3341b16a4 SHA512 7cb079d6ae889a744e2a3596b0eac737f7fdf1734c2024c71bb5ff85b93bff1d8ec26d61ee5b210aad4f0f9137968a6e256492c8c8376bafe2c5da2d12985a73
+DIST genimage-17.tar.gz 94853 BLAKE2B 371f35be1f47ecc012adcac5e6138f8bf32b097fd508b599d788d3a1af3fd0ccb9a213d0dc683ecc6e11f762e6376cf3a2683dec3fefd26e70ceebc48e7d2814 SHA512 b02415e030e2ef9ace40b965935e2634c208db4f4d401e1a824aa6dcf06c9656ba060d66e4a3a4306216ec74ce2ddcea4647bb68eb61a3bf4e9aadb1ff0d73ef
diff --git a/sys-fs/genimage/genimage-17.ebuild b/sys-fs/genimage/genimage-17.ebuild
new file mode 100644
index 000000000000..4becc18f6212
--- /dev/null
+++ b/sys-fs/genimage/genimage-17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pengutronix/genimage.git"
+else
+ SRC_URI="https://github.com/pengutronix/genimage/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64"
+fi
+
+DESCRIPTION="Tool to generate multiple filesystem and flash images from a tree"
+HOMEPAGE="https://github.com/pengutronix/genimage"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/confuse:="
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( sys-apps/fakeroot )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ optfeature "cpio support" app-alternatives/cpio
+ optfeature "tar support" app-arch/tar
+ optfeature "qemu support" app-emulation/qemu
+ optfeature "dosfstools support" sys-fs/dosfstools
+ optfeature "cramfs support" sys-fs/cramfs
+ optfeature "genext2fs support" sys-fs/genext2fs
+ optfeature "jffs, ubifs and ubinize support" sys-fs/mtd-utils
+ optfeature "squashfs support" sys-fs/squashfs-tools
+}