summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2023-07-09 13:12:37 +0200
committerSam James <sam@gentoo.org>2023-07-10 04:52:55 +0100
commit26dfe8a6674440cecdd75bf7f48e14e6cd536f75 (patch)
tree2ea89407ef378d40b2b501734efcd64396f89a73 /sys-fs
parentsys-fs/bees: add 0.10 (diff)
downloadgentoo-26dfe8a6674440cecdd75bf7f48e14e6cd536f75.tar.gz
gentoo-26dfe8a6674440cecdd75bf7f48e14e6cd536f75.tar.bz2
gentoo-26dfe8a6674440cecdd75bf7f48e14e6cd536f75.zip
sys-fs/bees: drop 0.8
Signed-off-by: Kai Krakow <kai@kaishome.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bees/Manifest1
-rw-r--r--sys-fs/bees/bees-0.8.ebuild109
-rw-r--r--sys-fs/bees/metadata.xml11
3 files changed, 4 insertions, 117 deletions
diff --git a/sys-fs/bees/Manifest b/sys-fs/bees/Manifest
index 49d473308e14..d7c0ed7ac2bc 100644
--- a/sys-fs/bees/Manifest
+++ b/sys-fs/bees/Manifest
@@ -1,3 +1,2 @@
DIST bees-0.10.tar.gz 177509 BLAKE2B 269cf65d5250a07297dfaee6c0fd6bc25199d63fe423d63ce39df8bcdb64d6f8110a0e03d0dc7dc1b105a8886f2a9364da8878481546eaa8dbf3dc46abc569ed SHA512 77a4ae3d66430c2d9dc0351c16c60bad95f21e238fc00f5f5787f55929ba75ee25212ac4bb4a3e4a9419cec27bbcfd2987aa925a54bc2872609b38a698dbedc3
-DIST bees-0.8.tar.gz 166890 BLAKE2B 26c7563ed1433526371d45e5f2f9e4f2a749e18f0d97e7a2ee445ef9d4cdf49210c8a96f756c04d19337497d12eacde28430f9ad64df198ff44c901b1bfc36c2 SHA512 92208ee186de18e764fab42f3de4e518047a21f4ed2429040a706fe7a45e0b2d39d1e468beefc92553659fc4587f4894a33d5a26bfd59278923208db3acc7da0
DIST bees-0.9.tar.gz 176570 BLAKE2B f210afc342debb9fcdaba977ecccee9c07929197ccda942566634ef4d08c8bd11edb67ea50e05b046771faad212a9c3e01fc98c74dc759785afa588ba1d68b06 SHA512 dce90fc6f1741356331cc8c43536ea497c41a702be1b2bc2196f9ad0d5083d7255f15d529cf2804e4f36675ccc4a1d11d25ee266071a984199706ae2cd285c43
diff --git a/sys-fs/bees/bees-0.8.ebuild b/sys-fs/bees/bees-0.8.ebuild
deleted file mode 100644
index 8c6ac6117418..000000000000
--- a/sys-fs/bees/bees-0.8.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info systemd toolchain-funcs
-
-DESCRIPTION="Best-Effort Extent-Same, a btrfs dedup agent"
-HOMEPAGE="https://github.com/Zygo/bees"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Zygo/bees.git"
-else
- SRC_URI="https://github.com/Zygo/bees/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="tools"
-
-DEPEND="
- >=sys-apps/util-linux-2.30.2
- >=sys-fs/btrfs-progs-4.20.2
-"
-RDEPEND="${DEPEND}"
-
-CONFIG_CHECK="~BTRFS_FS"
-ERROR_BTRFS_FS="CONFIG_BTRFS_FS: bees does currently only work with btrfs"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- if kernel_is -lt 4 11; then
- ewarn "With kernel versions below 4.11, bees may severely degrade system performance"
- ewarn "and responsiveness. Especially, the kernel may deadlock while bees is"
- ewarn "running, it's recommended to run at least kernel 4.11."
- ewarn
- elif kernel_is -lt 4 14 29; then
- ewarn "With kernel versions below 4.14.29, bees may generate a lot of bogus WARN_ON()"
- ewarn "messages in the kernel log. These messages can be ignored and this is fixed"
- ewarn "with more recent kernels:"
- ewarn "# WARNING: CPU: 3 PID: 18172 at fs/btrfs/backref.c:1391 find_parent_nodes+0xc41/0x14e0"
- ewarn
- elif kernel_is -lt 5 7 0; then
- ewarn "With kernel versions below 5.4.96 and 5.7, the kernel may hold file system"
- ewarn "locks for a long time while at the same time CPU usage increases when bees is"
- ewarn "operating. bees tries to avoid this behavior by excluding very common extents"
- ewarn "from deduplication. This has only a minimal impact on dedupe effectiveness."
- ewarn
- fi
- if kernel_is -lt 5 1 0; then
- ewarn "IMPORTANT: With kernel versions below 5.1.0, you may experience data corruption"
- ewarn "due to bees using compression in btrfs. You are adviced to use a chronologically"
- ewarn "later kernel, that includes older LTS versions released after 5.0.4:"
- ewarn "Fixed in: 5.1+, 5.0.4+, 4.19.31+, 4.14.108+, 4.9.165+, 4.4.177+, 3.18.137+"
- ewarn "# commit 8e92821 btrfs: fix corruption reading shared and compressed extents after hole punching"
- ewarn
- fi
- if kernel_is -lt 5 4 19; then
- ewarn "With kernel versions below 5.4.19, bees may trigger a btrfs bug when running"
- ewarn "btrfs-balance in parallel. This may lead to meta-data corruption in the worst"
- ewarn "case. Especially, kernels 5.1.21 and 5.2.21 should be avoided. Kernels 5.0.x"
- ewarn "after 5.0.21 should be safe. In the best case, affected kernels may force"
- ewarn "the device RO without writing corrupted meta-data. More details:"
- ewarn "https://github.com/Zygo/bees/blob/master/docs/btrfs-kernel.md"
- ewarn
- fi
- if kernel_is -ge 5 4 0; then
- ewarn "With kernel version 5.4 or later, the kernel may hang when multiple threads"
- ewarn "are running LOGICAL_INO and dedupe ioctl. This is not exclusively triggered"
- ewarn "by bees but also other software running such operations, bees will just more"
- ewarn "likely trigger this bug. You can work around this issue by reducing the"
- ewarn "thread count of bees to 1."
- ewarn
- fi
-
- elog "Bees recommends running the latest current kernel for performance and"
- elog "reliability reasons, see README.md."
- fi
-}
-
-src_prepare() {
- default
- sed -i 's/ -Werror//' makeflags || die
-}
-
-src_configure() {
- tc-export CC CXX AR
- cat >localconf <<-EOF || die
- ETC_PREFIX="${EPREFIX}/etc"
- LIBEXEC_PREFIX="${EPREFIX}/usr/libexec"
- PREFIX="${EPREFIX}/usr"
- SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
- DEFAULT_MAKE_TARGET=all
- EOF
- if [[ ${PV} != "9999" ]] ; then
- echo BEES_VERSION=v${PV} >>localconf || die
- fi
- if use tools; then
- echo OPTIONAL_INSTALL_TARGETS=install_tools >>localconf || die
- fi
-}
-
-src_compile() {
- default
- # localconf quotes leak in the systemd unit but are still needed for spaces
- sed -i 's/"//g' scripts/beesd@.service || die
-}
diff --git a/sys-fs/bees/metadata.xml b/sys-fs/bees/metadata.xml
index 29a9cccdbdf5..c7b55c3b67c7 100644
--- a/sys-fs/bees/metadata.xml
+++ b/sys-fs/bees/metadata.xml
@@ -9,11 +9,8 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
-<use>
- <flag name="tools">Build extra tools useful for debugging (fiemap, fiewalk)</flag>
-</use>
-<upstream>
- <bugs-to>https://github.com/Zygo/bees/issues</bugs-to>
- <remote-id type="github">Zygo/bees</remote-id>
-</upstream>
+ <upstream>
+ <bugs-to>https://github.com/Zygo/bees/issues</bugs-to>
+ <remote-id type="github">Zygo/bees</remote-id>
+ </upstream>
</pkgmetadata>